activesupport ruby 1.8.7 fix (v2.7.x) #1270

Closed
wants to merge 1 commit into
from

3 participants

@harisadam

activesupport (4.0.0) has dropped support for Ruby 1.8.7, so we need activesupport < 4.0.0 in the old branch.

@kasperite

I have had similar problem few days ago(Did a pull/request but cancelled it). In my case, it was because of a very old project which doesn't use bundler to manage dependencies. If you lock down your rails version then this is not an issue.

@hannahwolfe

Hi. I am currently trying to install paperclip 2.7 on a server with Ruby 1.8.7 and I am running into the error "Error installing paperclip: activesupport requires Ruby version >= 1.9.3." This project also doesn't use bundler to manage dependencies. Are there any temporary solutions? Thanks!

@harisadam

@hannahwolfe yea, just clone my fork then build a gem from gemspec file

@hannahwolfe

Thanks!

@harisadam harisadam closed this Jul 12, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment