Generator broken in Rails 4 #22

Closed
gsreynolds opened this Issue Sep 25, 2013 · 6 comments

Projects

None yet

5 participants

Under Rails 4.0.0, I get the following error when I run the generator:

$ rails g paul_revere
/Users/gavin/.rvm/gems/ruby-2.0.0-p195/gems/activesupport-4.0.0/lib/active_support/dependencies.rb:228:in `require': cannot load such file -- rails/generators/active_record/migration (LoadError)

Appears the generator needs to be amended to reflect recent changes in ActiveRecord: rails/generators/active_record/migration no longer exists and the next_migration_number method needs to be defined.

I'm still having the same issue as @gsreynolds. Was the pull request accepted?

+1. If there's a problem with the pull request let us know so we can do something about it?

morgler commented Dec 17, 2014

+1. Rails 4.0.1

@morgler morgler added a commit to morgler/paul_revere that referenced this issue Dec 17, 2014
@morgler morgler Fix issue #22
Using michalczapko's solution from michalczapko/delayed_job_active_record@5fb30de
1de746d
morgler commented Dec 17, 2014

Sorry, gsreynolds already created the same fix more than a year ago. Could you please merge his pull request?

Owner

I'll check this out today.

Owner

Fixed here - 5f9d8a7 - and in released 1.3 gem version.

@mjankowski mjankowski closed this Dec 17, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment