Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 31 lines (26 sloc) 1.337 kB
2b78030 @jferris Use a dynamic gemspec instead of generating one from the Rakefile; up…
jferris authored
1 $LOAD_PATH << File.join(File.dirname(__FILE__), 'lib')
56b0a04 @jferris Move into the Matchers namespace
jferris authored
2 require 'shoulda/matchers/version'
44a8206 @rmm5t Version bump to 2.0.4 to maintain consistency with VERSION constant
rmm5t authored
3
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
4 Gem::Specification.new do |s|
26fb35a @gabebw Use Bundler gem conventions.
gabebw authored
5 s.name = "shoulda-matchers"
6 s.version = Shoulda::Matchers::VERSION.dup
7 s.authors = ["Tammer Saleh", "Joe Ferris", "Ryan McGeary", "Dan Croak",
8 "Matt Jankowski", "Stafford Brunk"]
9 s.date = Time.now.strftime("%Y-%m-%d")
10 s.email = "support@thoughtbot.com"
11 s.homepage = "http://thoughtbot.com/community/"
12 s.summary = "Making tests easy on the fingers and eyes"
13 s.description = "Making tests easy on the fingers and eyes"
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
14
26fb35a @gabebw Use Bundler gem conventions.
gabebw authored
15 s.files = `git ls-files`.split("\n")
16 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
17 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
18 s.require_paths = ["lib"]
19
c65e43a @gabebw Depend on activesupport >= 3.0.0.
gabebw authored
20 s.add_dependency('activesupport', '>= 3.0.0')
21
1956736 @jodosha Bumped to latest dependencies
jodosha authored
22 s.add_development_dependency('appraisal', '~> 0.4.0')
3039cc6 @gabebw Alphabetize.
gabebw authored
23 s.add_development_dependency('aruba')
24 s.add_development_dependency('bourne', '~> 1.1.2')
2c214e4 @grantovich Whoops, don't use Bundler 1.0
grantovich authored
25 s.add_development_dependency('bundler', '~> 1.1')
3039cc6 @gabebw Alphabetize.
gabebw authored
26 s.add_development_dependency('cucumber', '~> 1.1.9')
1956736 @jodosha Bumped to latest dependencies
jodosha authored
27 s.add_development_dependency('rails', '~> 3.0')
3039cc6 @gabebw Alphabetize.
gabebw authored
28 s.add_development_dependency('rake', '~> 0.9.2')
5baa056 @gabebw Bump rspec-rails.
gabebw authored
29 s.add_development_dependency('rspec-rails', '~> 2.8.1')
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
30 end
Something went wrong with that request. Please try again.