Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 34 lines (29 sloc) 1.437 kb
2b78030 Joe Ferris Use a dynamic gemspec instead of generating one from the Rakefile; updat...
jferris authored
1 $LOAD_PATH << File.join(File.dirname(__FILE__), 'lib')
56b0a04 Joe Ferris Move into the Matchers namespace
jferris authored
2 require 'shoulda/matchers/version'
44a8206 Ryan McGeary Version bump to 2.0.4 to maintain consistency with VERSION constant
rmm5t authored
3
c027272 Ryan McGeary Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
4 Gem::Specification.new do |s|
26fb35a Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
5 s.name = "shoulda-matchers"
6 s.version = Shoulda::Matchers::VERSION.dup
7 s.authors = ["Tammer Saleh", "Joe Ferris", "Ryan McGeary", "Dan Croak",
8 "Matt Jankowski", "Stafford Brunk"]
9 s.date = Time.now.strftime("%Y-%m-%d")
10 s.email = "support@thoughtbot.com"
11 s.homepage = "http://thoughtbot.com/community/"
12 s.summary = "Making tests easy on the fingers and eyes"
37bb7dc Jordi Massaguer Pla add license information to gemspec
jordimassaguerpla authored
13 s.license = "MIT"
26fb35a Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
14 s.description = "Making tests easy on the fingers and eyes"
c027272 Ryan McGeary Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
15
26fb35a Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
16 s.files = `git ls-files`.split("\n")
17 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
18 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
c027272 Ryan McGeary Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
19 s.require_paths = ["lib"]
20
c65e43a Gabe Berke-Williams Depend on activesupport >= 3.0.0.
gabebw authored
21 s.add_dependency('activesupport', '>= 3.0.0')
b793604 Dan Croak Loosen Bourne dependency to ~> 1.3
croaky authored
22 s.add_dependency('bourne', '~> 1.3')
c65e43a Gabe Berke-Williams Depend on activesupport >= 3.0.0.
gabebw authored
23
6cb0052 Dan Croak Consistently use ~> 'maj.min' on dev dependencies
croaky authored
24 s.add_development_dependency('appraisal', '~> 0.5')
25 s.add_development_dependency('aruba', '~> 0.5')
26 s.add_development_dependency('bundler', '~> 1.1')
27 s.add_development_dependency('cucumber', '~> 1.1')
28 s.add_development_dependency('rails', '~> 3.0')
29 s.add_development_dependency('rake', '~> 10.0')
30 s.add_development_dependency('rspec', '~> 2.13')
b793604 Dan Croak Loosen Bourne dependency to ~> 1.3
croaky authored
31 s.add_development_dependency('rspec-rails', '~> 2.13')
6cb0052 Dan Croak Consistently use ~> 'maj.min' on dev dependencies
croaky authored
32 s.add_development_dependency('strong_parameters', '~> 0.2')
c027272 Ryan McGeary Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
33 end
Something went wrong with that request. Please try again.