Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Bump version to 2.0.0

  • Loading branch information...
commit 8d93d9d4984792b90cfab78bf03e50a7796ad759 1 parent 3ec4c00
Melissa Xie mxie authored mxie committed
2  Gemfile.lock
View
@@ -1,7 +1,7 @@
PATH
remote: .
specs:
- shoulda-matchers (1.5.6)
+ shoulda-matchers (2.0.0)
activesupport (>= 3.0.0)
GEM
12 NEWS.md
View
@@ -1,5 +1,17 @@
# HEAD
+# v 2.0.0
+* Remove the following matchers:
+ * `assign_to`
+ * `respond_with_content_type`
+ * `query_the_database`
+ * `validate_format_of`
+ * `have_sent_email`
+ * `permit` (strong parameters matcher)
+ * `delegate_method`
+* For more information about 2.0 changes, see:
+http://robots.thoughtbot.com/post/47031676783/shoulda-matchers-2-0
+
# v 1.5.6
* Revert previous change in `AllowValueMatcher` that added a check for a
properly-set attribute.
2  gemfiles/3.0.gemfile.lock
View
@@ -1,7 +1,7 @@
PATH
remote: /Users/melissaxie/thoughtbot/shoulda-matchers
specs:
- shoulda-matchers (1.5.6)
+ shoulda-matchers (2.0.0)
activesupport (>= 3.0.0)
GEM
2  gemfiles/3.1.gemfile.lock
View
@@ -1,7 +1,7 @@
PATH
remote: /Users/melissaxie/thoughtbot/shoulda-matchers
specs:
- shoulda-matchers (1.5.6)
+ shoulda-matchers (2.0.0)
activesupport (>= 3.0.0)
GEM
2  gemfiles/3.2.gemfile.lock
View
@@ -1,7 +1,7 @@
PATH
remote: /Users/melissaxie/thoughtbot/shoulda-matchers
specs:
- shoulda-matchers (1.5.6)
+ shoulda-matchers (2.0.0)
activesupport (>= 3.0.0)
GEM
2  lib/shoulda/matchers/version.rb
View
@@ -1,5 +1,5 @@
module Shoulda
module Matchers
- VERSION = '1.5.6'.freeze
+ VERSION = '2.0.0'.freeze
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.