Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Consistently use ~> 'maj.min' on dev dependencies

Upgrade Rake, Strong Parameters.
  • Loading branch information...
commit 6cb0052c5cfb8a4e4b02eade9a2f7e6bc23f4b54 1 parent aaca716
@croaky croaky authored drapergeek committed
Showing with 21 additions and 15 deletions.
  1. +13 −8 Gemfile.lock
  2. +8 −7 shoulda-matchers.gemspec
View
21 Gemfile.lock
@@ -97,6 +97,10 @@ GEM
rake (10.0.3)
rdoc (3.12.2)
json (~> 1.4)
+ rspec (2.13.0)
+ rspec-core (~> 2.13.0)
+ rspec-expectations (~> 2.13.0)
+ rspec-mocks (~> 2.13.0)
rspec-core (2.13.1)
rspec-expectations (2.13.0)
diff-lcs (>= 1.1.3, < 2.0)
@@ -115,10 +119,10 @@ GEM
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
sqlite3 (1.3.6)
- strong_parameters (0.1.5)
- actionpack (~> 3.1)
- activemodel (~> 3.1)
- railties (~> 3.1)
+ strong_parameters (0.2.0)
+ actionpack (~> 3.0)
+ activemodel (~> 3.0)
+ railties (~> 3.0)
thor (0.17.0)
tilt (1.3.6)
treetop (1.4.12)
@@ -132,17 +136,18 @@ PLATFORMS
DEPENDENCIES
activerecord-jdbc-adapter
activerecord-jdbcsqlite3-adapter
- appraisal (~> 0.4)
- aruba
+ appraisal (~> 0.5)
+ aruba (~> 0.5)
bundler (~> 1.1)
cucumber (~> 1.1)
jdbc-sqlite3
jruby-openssl
rails (~> 3.0)
- rake (>= 0.9.2)
+ rake (~> 10.0)
+ rspec (~> 2.13)
rspec-rails (~> 2.13)
shoulda-context (~> 1.0.0)
shoulda-matchers!
sqlite3
- strong_parameters
+ strong_parameters (~> 0.2)
therubyrhino
View
15 shoulda-matchers.gemspec
@@ -21,12 +21,13 @@ Gem::Specification.new do |s|
s.add_dependency('activesupport', '>= 3.0.0')
s.add_dependency('bourne', '~> 1.3')
- s.add_development_dependency('appraisal', '~> 0.4')
- s.add_development_dependency('aruba')
- s.add_development_dependency('bundler', '~> 1.1')
- s.add_development_dependency('cucumber', '~> 1.1')
- s.add_development_dependency('rails', '~> 3.0')
- s.add_development_dependency('rake', '>= 0.9.2')
+ s.add_development_dependency('appraisal', '~> 0.5')
+ s.add_development_dependency('aruba', '~> 0.5')
+ s.add_development_dependency('bundler', '~> 1.1')
+ s.add_development_dependency('cucumber', '~> 1.1')
+ s.add_development_dependency('rails', '~> 3.0')
+ s.add_development_dependency('rake', '~> 10.0')
+ s.add_development_dependency('rspec', '~> 2.13')
s.add_development_dependency('rspec-rails', '~> 2.13')
- s.add_development_dependency('strong_parameters')
+ s.add_development_dependency('strong_parameters', '~> 0.2')
end
Please sign in to comment.
Something went wrong with that request. Please try again.