v4.0

No due date 96% complete

This release adds support for Ruby 2.4 and Rails 5.1, dropping support for Ruby 2.0 and 2.1 as well as Rails 4.0 and 4.1.