Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 33 lines (28 sloc) 1.207 kb
2b78030 @jferris Use a dynamic gemspec instead of generating one from the Rakefile; updat...
jferris authored
1 $LOAD_PATH << File.join(File.dirname(__FILE__), 'lib')
46076d5 @jferris Created shoulda metagem
jferris authored
2 require 'shoulda/version'
44a8206 @rmm5t Version bump to 2.0.4 to maintain consistency with VERSION constant
rmm5t authored
3
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
4 Gem::Specification.new do |s|
46076d5 @jferris Created shoulda metagem
jferris authored
5 s.name = %q{shoulda}
6 s.version = Shoulda::VERSION
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
7
8 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
2b78030 @jferris Use a dynamic gemspec instead of generating one from the Rakefile; updat...
jferris authored
9 s.authors = ["Tammer Saleh", "Joe Ferris", "Ryan McGeary", "Dan Croak",
10 "Matt Jankowski"]
f814549 @jferris Generate a date in the gemspec so we don't keep pushing the wrong date
jferris authored
11 s.date = Time.now.strftime("%Y-%m-%d")
46076d5 @jferris Created shoulda metagem
jferris authored
12 s.default_executable = %q{convert_to_should_syntax}
2b78030 @jferris Use a dynamic gemspec instead of generating one from the Rakefile; updat...
jferris authored
13 s.email = %q{support@thoughtbot.com}
46076d5 @jferris Created shoulda metagem
jferris authored
14 s.executables = ["convert_to_should_syntax"]
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
15 s.extra_rdoc_files = ["README.rdoc", "CONTRIBUTION_GUIDELINES.rdoc"]
2b78030 @jferris Use a dynamic gemspec instead of generating one from the Rakefile; updat...
jferris authored
16 s.files = Dir["[A-Z]*", "{bin,lib,rails,test}/**/*"]
17 s.homepage = %q{http://thoughtbot.com/community/}
f995967 @jferris Bumped to version 2.9.2
jferris authored
18 s.rdoc_options = ["--line-numbers", "--main", "README.rdoc"]
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
19 s.require_paths = ["lib"]
46076d5 @jferris Created shoulda metagem
jferris authored
20 s.rubyforge_project = %q{shoulda}
975bf8a @joshuaclayton Update gemspec
joshuaclayton authored
21 s.rubygems_version = %q{1.3.5}
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
22 s.summary = %q{Making tests easy on the fingers and eyes}
2b78030 @jferris Use a dynamic gemspec instead of generating one from the Rakefile; updat...
jferris authored
23 s.description = %q{Making tests easy on the fingers and eyes}
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
24
46076d5 @jferris Created shoulda metagem
jferris authored
25 s.add_runtime_dependency(%q<shoulda-context>)
26 s.add_runtime_dependency(%q<shoulda-matchers>)
27
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
28 if s.respond_to? :specification_version then
39f3e5b @qrush Bumping to 2.10.2
qrush authored
29 s.specification_version = 3
c027272 @rmm5t Published GitHub gemspec; Assigned gem version to 2.0.0;
rmm5t authored
30 else
31 end
32 end
Something went wrong with that request. Please try again.