Permalink
Browse files

Relaxed dependencies to allow shoulda-matchers 2.x

  • Loading branch information...
1 parent 86e39e5 commit 0f5e292a36e885ac046824344fde66cb3471e0b8 @rmm5t rmm5t committed May 7, 2013
Showing with 7 additions and 25 deletions.
  1. +2 −8 gemfiles/3.0.gemfile.lock
  2. +2 −8 gemfiles/3.1.gemfile.lock
  3. +2 −8 gemfiles/3.2.gemfile.lock
  4. +1 −1 shoulda.gemspec
@@ -3,7 +3,7 @@ PATH
specs:
shoulda (3.4.0)
shoulda-context (~> 1.0, >= 1.0.1)
- shoulda-matchers (>= 1.4.1, < 2.0)
+ shoulda-matchers (>= 1.4.1, < 3.0)
GEM
remote: https://rubygems.org/
@@ -44,8 +44,6 @@ GEM
cucumber (>= 1.1.1)
ffi (>= 1.0.11)
rspec (>= 2.7.0)
- bourne (1.4.0)
- mocha (~> 0.13.2)
builder (2.1.2)
childprocess (0.3.9)
ffi (~> 1.0, >= 1.0.11)
@@ -68,10 +66,7 @@ GEM
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- metaclass (0.0.1)
mime-types (1.23)
- mocha (0.13.3)
- metaclass (~> 0.0.1)
polyglot (0.3.3)
rack (1.2.8)
rack-mount (0.6.14)
@@ -109,9 +104,8 @@ GEM
railties (~> 3.0)
rspec (~> 2.7.0)
shoulda-context (1.1.1)
- shoulda-matchers (1.5.6)
+ shoulda-matchers (2.1.0)
activesupport (>= 3.0.0)
- bourne (~> 1.3)
sqlite3 (1.3.7)
term-ansicolor (1.1.5)
thor (0.14.6)
@@ -3,7 +3,7 @@ PATH
specs:
shoulda (3.4.0)
shoulda-context (~> 1.0, >= 1.0.1)
- shoulda-matchers (>= 1.4.1, < 2.0)
+ shoulda-matchers (>= 1.4.1, < 3.0)
GEM
remote: https://rubygems.org/
@@ -45,8 +45,6 @@ GEM
cucumber (>= 1.1.1)
ffi (>= 1.0.11)
rspec (>= 2.7.0)
- bourne (1.4.0)
- mocha (~> 0.13.2)
builder (3.0.4)
childprocess (0.3.9)
ffi (~> 1.0, >= 1.0.11)
@@ -71,10 +69,7 @@ GEM
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- metaclass (0.0.1)
mime-types (1.23)
- mocha (0.13.3)
- metaclass (~> 0.0.1)
multi_json (1.7.3)
polyglot (0.3.3)
rack (1.3.10)
@@ -123,9 +118,8 @@ GEM
railties (~> 3.1.0)
sass (>= 3.1.4)
shoulda-context (1.1.1)
- shoulda-matchers (1.5.6)
+ shoulda-matchers (2.1.0)
activesupport (>= 3.0.0)
- bourne (~> 1.3)
sprockets (2.0.4)
hike (~> 1.2)
rack (~> 1.0)
@@ -3,7 +3,7 @@ PATH
specs:
shoulda (3.4.0)
shoulda-context (~> 1.0, >= 1.0.1)
- shoulda-matchers (>= 1.4.1, < 2.0)
+ shoulda-matchers (>= 1.4.1, < 3.0)
GEM
remote: https://rubygems.org/
@@ -44,8 +44,6 @@ GEM
cucumber (>= 1.1.1)
ffi (>= 1.0.11)
rspec (>= 2.7.0)
- bourne (1.4.0)
- mocha (~> 0.13.2)
builder (3.0.4)
childprocess (0.3.9)
ffi (~> 1.0, >= 1.0.11)
@@ -71,10 +69,7 @@ GEM
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- metaclass (0.0.1)
mime-types (1.23)
- mocha (0.13.3)
- metaclass (~> 0.0.1)
multi_json (1.7.3)
polyglot (0.3.3)
rack (1.4.5)
@@ -121,9 +116,8 @@ GEM
sass (>= 3.1.10)
tilt (~> 1.3)
shoulda-context (1.1.1)
- shoulda-matchers (1.5.6)
+ shoulda-matchers (2.1.0)
activesupport (>= 3.0.0)
- bourne (~> 1.3)
sprockets (2.1.3)
hike (~> 1.2)
rack (~> 1.0)
View
@@ -19,7 +19,7 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
s.add_dependency("shoulda-context", ["~> 1.0", ">= 1.0.1"])
- s.add_dependency("shoulda-matchers", [">= 1.4.1", "< 2.0"])
+ s.add_dependency("shoulda-matchers", [">= 1.4.1", "< 3.0"])
s.add_development_dependency('appraisal', '~> 0.4.0')
s.add_development_dependency("rails", "3.0.12")

0 comments on commit 0f5e292

Please sign in to comment.