Skip to content
Browse files

Specify pessimistic version constraint with two digits of precision

Assumes semantic versioning of `shoulda-context` and `shoulda-matchers`.
See also: #232.
  • Loading branch information...
1 parent 2c09e79 commit b180166b2f5e59443598cf59502f900a764dfc1a @sferik sferik committed
Showing with 2 additions and 2 deletions.
  1. +2 −2 shoulda.gemspec
View
4 shoulda.gemspec
@@ -18,8 +18,8 @@ Gem::Specification.new do |s|
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.add_dependency("shoulda-context", "~> 1.0.1")
- s.add_dependency("shoulda-matchers", "~> 1.4.1")
+ s.add_dependency("shoulda-context", ["~> 1.0", ">= 1.0.1"])
+ s.add_dependency("shoulda-matchers", ["~> 1.0", ">= 1.4.1"])
s.add_development_dependency('appraisal', '~> 0.4.0')
s.add_development_dependency("rails", "3.0.12")

0 comments on commit b180166

Please sign in to comment.
Something went wrong with that request. Please try again.