Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

errors on rspec:install #169

Closed
rkcudjoe opened this Issue · 1 comment

2 participants

Raymond Cudjoe Dan Croak
Raymond Cudjoe

Using latest version of suspenders. It fails on rspec:install and spec_helper file is never generated.
I think this is the relevant part of the errors:
generate rspec:install
...
remove .rspec
create .rspec
prepend spec/spec_helper.rb
~/.rvm/gems/ruby-1.9.3-p385/gems/thor-0.17.0/lib/thor/actions/inject_into_file.rb:99:in `binread': No such file or directory - /Users/rkcudjoe/code/rails/contacts/spec/spec_helper.rb (Errno::ENOENT)
Any tips on how to fix this before an update?

Dan Croak
Admin

@rkcudjoe Thanks for the bug report. I've been able to reproduce this and isolate it to the database not existing before the RSpec generator is run, which now needs the database.

Fixed in 969dbd9.

Dan Croak croaky closed this
EdinaVath EdinaVath referenced this issue from a commit in EdinaVath/suspenders
Dan Croak croaky Set up database before setting up RSpec 969dbd9
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.