Suspenders installs conflicting rspec binary #288

Closed
jferris opened this Issue Feb 19, 2014 · 1 comment

Comments

Projects
None yet
2 participants
@jferris
Owner

jferris commented Feb 19, 2014

While installing suspenders:

% gem install suspenders          
suspenders's executable "rspec" conflicts with rspec-core
Overwrite the executable? [yN]

This is because we added an rspec binstub to bin/ and automatically distribute all files in bin/ in the .gemspec. We probably want to explicitly distribute suspenders and nothing else in our .gemspec.

croaky added a commit that referenced this issue Feb 19, 2014

Distribute bin/suspenders, not bin/rspec, in gem
While installing suspenders:

    % gem install suspenders
    suspenders's executable "rspec" conflicts with rspec-core
    Overwrite the executable? [yN]

This is because we added an `rspec` binstub to `bin/` and automatically
distribute all files in `bin/` in the `.gemspec.`

Resolves #288
@croaky

This comment has been minimized.

Show comment Hide comment
@croaky

croaky Feb 19, 2014

Contributor

@jferris How does #289 look?

Contributor

croaky commented Feb 19, 2014

@jferris How does #289 look?

@croaky croaky closed this Feb 19, 2014

croaky added a commit that referenced this issue Feb 19, 2014

Distribute bin/suspenders, not bin/rspec, in gem
While installing suspenders:

    % gem install suspenders
    suspenders's executable "rspec" conflicts with rspec-core
    Overwrite the executable? [yN]

This is because we added an `rspec` binstub to `bin/` and automatically
distribute all files in `bin/` in the `.gemspec.`

Resolves #288
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment