Skip to content
This repository

`to_sym': interning empty string (ArgumentError) #89

Closed
danawoodman opened this Issue · 2 comments

2 participants

Dana Woodman Dan Croak
Dana Woodman

Really loving all your team's open source projects, grateful for your contributions! Thanks!


So, I've been getting a strange error that I've been attempting to diagnose, but failing:

$   sudo gem install suspenders
$   cd code/
$   suspenders myapp
/Library/Ruby/Gems/1.8/gems/railties-3.2.6/lib/rails/generators/base.rb:320:in `to_sym': interning empty string (ArgumentError)
    from /Library/Ruby/Gems/1.8/gems/railties-3.2.6/lib/rails/generators/base.rb:320:in `default_for_option'
    from /Library/Ruby/Gems/1.8/gems/railties-3.2.6/lib/rails/generators/base.rb:314:in `default_aliases_for_option'
    from /Library/Ruby/Gems/1.8/gems/railties-3.2.6/lib/rails/generators/base.rb:199:in `class_option'
    from /Library/Ruby/Gems/1.8/gems/suspenders-1.0.0/lib/suspenders/generators/app_generator.rb:7
    from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:55:in `gem_original_require'
    from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:55:in `require'
    from /Library/Ruby/Gems/1.8/gems/suspenders-1.0.0/bin/suspenders:3
    from /usr/bin/suspenders:23:in `load'
    from /usr/bin/suspenders:23

I've installed qt with Homebrew in addition to making sure PostgreSQL is up and running.

Not sure if I'm missing something or what else it could be.

I'm running:

  • MacOSX 10.6.8
  • Rails 3.2.6
  • Bundler 1.1.3
  • Gem 1.8.24

Thanks for any tips!

Dan Croak
Owner

This was a Ruby 1.8-specific issue. I tested it on REE and fixed in 27a2542. Will push a Suspenders 1.0.1 gem tonight. Cheers!

Dan Croak croaky closed this
Dana Woodman

Awesome, thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.