Can't build vacuum-cairo and vacuum-graphviz with 7.6.2 #5

Open
rodlogic opened this Issue Mar 19, 2013 · 2 comments

Comments

Projects
None yet
3 participants
@rodlogic

Resolving dependencies...
Configuring strict-concurrency-0.2.4.1...
Building strict-concurrency-0.2.4.1...
Preprocessing library strict-concurrency-0.2.4.1...

on the commandline: Warning:
    -fglasgow-exts is deprecated: Use individual extensions instead

Control/Concurrent/MVar/Strict.hs:46:8:
    Could not find module `Control.OldException'
    Perhaps you meant Control.Exception (from base)
    Use -v to see a list of the files searched for.
Failed to install strict-concurrency-0.2.4.1
cabal: Error: some packages failed to install:
strict-concurrency-0.2.4.1 failed during the building phase. The exception
was:
ExitFailure 1
vacuum-cairo-0.5 depends on strict-concurrency-0.2.4.1 which failed to
install.
@bitemyapp

This comment has been minimized.

Show comment
Hide comment
@bitemyapp

bitemyapp Feb 4, 2014

I'm still having problems with this, 11 months later. Has anybody found a solution? I scoured the IRC channel history to no avail.

Oh, base 4.6 moved/removed it. Dammit. It looks like it existed in 4.2.

I'm still having problems with this, 11 months later. Has anybody found a solution? I scoured the IRC channel history to no avail.

Oh, base 4.6 moved/removed it. Dammit. It looks like it existed in 4.2.

@ygale

This comment has been minimized.

Show comment
Hide comment
@ygale

ygale Aug 30, 2017

The strict-concurrency package now works again. Vacuum still doesn't build on modern GHC, but that is for other reasons. This issue can be closed.

ygale commented Aug 30, 2017

The strict-concurrency package now works again. Vacuum still doesn't build on modern GHC, but that is for other reasons. This issue can be closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment