Permalink
Browse files

Reverted making gemspec the source of gem dependencies since we use

jeweler to generate the gemspec
  • Loading branch information...
1 parent 3aaa8b3 commit 75d00b316adb9ab587ab430a66b61705ebc239f6 @thuss committed Feb 25, 2013
Showing with 79 additions and 23 deletions.
  1. +11 −1 Gemfile
  2. +59 −10 Gemfile.lock
  3. +9 −12 standalone_migrations.gemspec
View
12 Gemfile
@@ -1,2 +1,12 @@
source :rubygems
-gemspec
+
+gem 'rake'
+gem 'activerecord', ENV['AR'] || '~>3.2.11'
+gem 'railties', ENV['AR'] || '~>3.2.11'
+
+group :dev do
+ gem 'sqlite3'
+ gem 'rspec', '~>2'
+ gem 'jeweler'
+end
+
View
@@ -1,19 +1,58 @@
-PATH
- remote: .
- specs:
- standalone_migrations (2.0.4)
- standalone_migrations
-
GEM
remote: http://rubygems.org/
specs:
+ actionpack (3.2.11)
+ activemodel (= 3.2.11)
+ activesupport (= 3.2.11)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ journey (~> 1.0.4)
+ rack (~> 1.4.0)
+ rack-cache (~> 1.2)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.2.1)
+ activemodel (3.2.11)
+ activesupport (= 3.2.11)
+ builder (~> 3.0.0)
+ activerecord (3.2.11)
+ activemodel (= 3.2.11)
+ activesupport (= 3.2.11)
+ arel (~> 3.0.2)
+ tzinfo (~> 0.3.29)
+ activesupport (3.2.11)
+ i18n (~> 0.6)
+ multi_json (~> 1.0)
+ arel (3.0.2)
+ builder (3.0.4)
diff-lcs (1.1.3)
+ erubis (2.7.0)
git (1.2.5)
+ hike (1.2.1)
+ i18n (0.6.1)
jeweler (1.6.4)
bundler (~> 1.0)
git (>= 1.2.5)
rake
+ journey (1.0.4)
+ json (1.7.6)
+ multi_json (1.5.0)
+ rack (1.4.4)
+ rack-cache (1.2)
+ rack (>= 0.4)
+ rack-ssl (1.3.3)
+ rack
+ rack-test (0.6.2)
+ rack (>= 1.0)
+ railties (3.2.11)
+ actionpack (= 3.2.11)
+ activesupport (= 3.2.11)
+ rack-ssl (~> 1.3.2)
+ rake (>= 0.8.7)
+ rdoc (~> 3.4)
+ thor (>= 0.14.6, < 2.0)
rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
rspec (2.7.0)
rspec-core (~> 2.7.0)
rspec-expectations (~> 2.7.0)
@@ -22,13 +61,23 @@ GEM
rspec-expectations (2.7.0)
diff-lcs (~> 1.1.2)
rspec-mocks (2.7.0)
+ sprockets (2.2.2)
+ hike (~> 1.2)
+ multi_json (~> 1.0)
+ rack (~> 1.0)
+ tilt (~> 1.1, != 1.3.0)
sqlite3 (1.3.6)
+ thor (0.17.0)
+ tilt (1.3.3)
+ tzinfo (0.3.35)
PLATFORMS
ruby
DEPENDENCIES
- jeweler (~> 1.6.4)
- rspec (~> 2.7.0)
- sqlite3 (~> 1.3.6)
- standalone_migrations!
+ activerecord (~> 3.2.11)
+ jeweler
+ railties (~> 3.2.11)
+ rake
+ rspec (~> 2)
+ sqlite3
@@ -53,21 +53,18 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<standalone_migrations>, [">= 0"])
- s.add_development_dependency(%q<sqlite3>, ["~> 1.3.6"])
- s.add_development_dependency(%q<rspec>, ["~> 2.7.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.6.4"])
+ s.add_runtime_dependency(%q<rake>, [">= 0"])
+ s.add_runtime_dependency(%q<activerecord>, ["~> 3.2.11"])
+ s.add_runtime_dependency(%q<railties>, ["~> 3.2.11"])
else
- s.add_dependency(%q<standalone_migrations>, [">= 0"])
- s.add_dependency(%q<sqlite3>, ["~> 1.3.6"])
- s.add_dependency(%q<rspec>, ["~> 2.7.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
+ s.add_dependency(%q<rake>, [">= 0"])
+ s.add_dependency(%q<activerecord>, ["~> 3.2.11"])
+ s.add_dependency(%q<railties>, ["~> 3.2.11"])
end
else
- s.add_dependency(%q<standalone_migrations>, [">= 0"])
- s.add_dependency(%q<sqlite3>, ["~> 1.3.6"])
- s.add_dependency(%q<rspec>, ["~> 2.7.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
+ s.add_dependency(%q<rake>, [">= 0"])
+ s.add_dependency(%q<activerecord>, ["~> 3.2.11"])
+ s.add_dependency(%q<railties>, ["~> 3.2.11"])
end
end

0 comments on commit 75d00b3

Please sign in to comment.