Bump library version constraints to accomodate GHC 7.6 boot package versions #43

Merged
merged 1 commit into from Aug 13, 2012
@@ -36,7 +36,7 @@ library
Data.HashMap.UnsafeShift
build-depends:
- base >= 4 && < 4.6,
+ base >= 4 && < 4.7,
deepseq >= 1.1 && < 1.4,
hashable >= 1.0.1.1 && < 1.2
@@ -58,7 +58,7 @@ test-suite hashmap-lazy-properties
build-depends:
base,
- containers >= 0.4.1 && < 0.5,
+ containers >= 0.4.1 && < 0.6,
hashable >= 1.0.1.1 && < 1.2,
QuickCheck >= 2.4.0.1,
test-framework >= 0.3.3 && < 0.7,
@@ -75,7 +75,7 @@ test-suite hashmap-strict-properties
build-depends:
base,
- containers >= 0.4.1 && < 0.5,
+ containers >= 0.4.1 && < 0.6,
hashable >= 1.0.1.1 && < 1.2,
QuickCheck >= 2.4.0.1,
test-framework >= 0.3.3 && < 0.7,
@@ -92,7 +92,7 @@ test-suite hashset-properties
build-depends:
base,
- containers >= 0.4.2 && < 0.5,
+ containers >= 0.4.2 && < 0.6,
hashable >= 1.0.1.1 && < 1.2,
QuickCheck >= 2.4.0.1,
test-framework >= 0.3.3 && < 0.7,