Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Solaris CRAN test error #575

Closed
wlandau opened this issue Sep 6, 2017 · 3 comments
Closed

Solaris CRAN test error #575

wlandau opened this issue Sep 6, 2017 · 3 comments

Comments

@wlandau
Copy link

@wlandau wlandau commented Sep 6, 2017

See the log for version 1.6.0. Possibly related: #574.

@vspinu
Copy link
Member

@vspinu vspinu commented Oct 1, 2017

Not sure how I can fix this without access to solaris. My current bandwidth doesn't allow me to target that platform, sorry.

It's almost surely unrelated to #574.

vspinu added a commit that referenced this issue Oct 7, 2017
@vspinu
Copy link
Member

@vspinu vspinu commented Oct 30, 2017

The above was fixed in 1.7.0 but there is one new issue related to time zones. We are now relying on time-zone manipulation and it looks like CCTZ cannot find zoneinfo on that platform. User can fix it by setting the TZDIR environment on that platform. I could also try setting it on lubridate's startup if it's not set.

@vspinu
Copy link
Member

@vspinu vspinu commented Oct 30, 2017

Actually I am already setting TZDIR on windows:) Will fix this for the next release.

@vspinu vspinu closed this in a55725c Oct 30, 2017
cderv added a commit to cderv/lubridate that referenced this issue Nov 1, 2017
vspinu added a commit that referenced this issue Nov 1, 2017
Correctly set TZDIR env (#575)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants