Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Make sure to attach packages from the same libary they were loaded from in `.onAttach()` #171

Closed
gaborcsardi opened this issue Feb 25, 2019 · 1 comment

Comments

@gaborcsardi
Copy link
Contributor

commented Feb 25, 2019

This is similar to r-lib/devtools#1987

It comes up during installation, when updating a dependency.

@gaborcsardi

This comment has been minimized.

Copy link
Contributor Author

commented Feb 25, 2019

I'll submit a PR soon.

gaborcsardi added a commit to gaborcsardi/tidyverse that referenced this issue Feb 25, 2019

Attach packages from same lib they were loaded from
Otherwise install.packages() test loading might run
into trouble, if the package versions are different,
and (in some way) incompatible.

Closes tidyverse#171.

@hadley hadley added bug wip labels May 10, 2019

@hadley hadley closed this in #172 May 10, 2019

hadley added a commit that referenced this issue May 10, 2019

Attach packages from same lib they were loaded from (#172)
Otherwise install.packages() test loading might run
into trouble, if the package versions are different,
and (in some way) incompatible.

Closes #171.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.