Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Branch: master
Fetching contributors…

Cannot retrieve contributors at this time

29 lines (18 sloc) 1.066 kB

Minimee

Version 1.1.7

Requirements:

  • PHP5
  • ExpressionEngine 2.1 or later
  • For HTML Minification, EE2.4 or later is required

Description

Minimize, combine & cache your CSS and JS files. Minify your HTML. Because size DOES matter.

Minimee is to EE2 what SL Combinator is to EE1. But with a few twists:

  • for EE2.4 and above, can minify your HTML
  • works with the global variables, even {stylesheet}
  • works with external files, over cURL or file_get_contents()
  • embed combined & minified content directly inline to your template
  • queue files for later
  • compatible with server-side compression & caching

Minimee is inspired and influenced by SL Combinator from Experience Internet, and Carabiner Asset Management Library from Tony Dewan. It is released under a BSD License.

Complete and up-to-date documentation can be found on Minimee’s homepage.

Jump to Line
Something went wrong with that request. Please try again.