Skip to content
RxJS JavaScript interoperability bindings for GWT 2.8
Java JavaScript HTML
Branch: 5.x.x
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
gwt-rxjs-jsinterop-generator
gwt-rxjs-jsinterop-onpage
gwt-rxjs-jsinterop-test-bundle
gwt-rxjs-jsinterop-test
gwt-rxjs-jsinterop
.gitignore
.travis.yml
CHANGELOG.md
LICENSE
README.md
pom.xml

README.md

gwt-rxjs-jsinterop (GWT rxjs interop)

Build Status Maven Central

RxJS 6.x.x JavaScript interoperability bindings see at master branch

RxJS 5.x.x JavaScript interoperability bindings for GWT 2.8

Supported rxjs versions list (starting from RxJS 5.5.11 versions are synched to simplify versions mapping):

rxjs gwt-rxjs-jsinterop
5.5.11 5.5.11-x
5.5.6 >= 1.1.7
5.4.1 >= 1.1.5
5.0.3 <= 1.1.4

Add dependency to your pom.xml:

<dependency>
    <groupId>com.github.timofeevda</groupId>
    <artifactId>gwt-rxjs-jsinterop</artifactId>
    <version>${version}</version>
</dependency>

Update your GWT module with the following line:

<inherits name="com.github.timofeevda.gwt.rxjs.interop"/>

Also add following entry in gwt-maven-plugin configuration:

<generateJsInteropExports>true</generateJsInteropExports>

Don't forget to add actual rxjs library to page resources

Note: for building on Linux systems add -Dphantomjs.binary option pointing it to PhantomJS binary location. On Windows PhantomJS is installed automatically during build.

You can’t perform that action at this time.