Skip to content
This repository
Fetching contributors…

Cannot retrieve contributors at this time

file 87 lines (56 sloc) 2.067 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87

-- BUGS --

* match offset of fill patterns across all layers

* fix rest amounts of antiooze

* make 2D mode usable
  + lost circles at SVG input
  + gcode generation

* layer detection at GCode cursor position

* double entries in serial speed

* win32
  + GL window size on Win7 64bit


-- IMPROVEMENTS --

* make model have a list of selected shapes instead of treeview-path?


-- FEATURES --


* machine specific GCode?
  + Create a wizard to select a default machine to base settings on ...
+ load a Settings object ...
+ have a directory-list of settings.xml
+ drop one in there ...
+ add a 'Name' field ...
+ add an 'Icon' field ...
  + Make multiple machine settings pleasantly
    configurable and selectable ...

* 360° arcs / arcs least squares fit (probably)

* thin polygons infill line (centreline)


* win32
  + serial



--- the plan ---

* add a git hook to forbid DOS line endings [!] ...


* Add low prio idle handler for error dialogs: can't connect to device eg.
* show heat on in a better way ...

* Bin the two 'load' menu items - just one 'open' menu ...
+ with a gcode and stl filter drop-down ?

* Add a right-click menu to the back-drop, so we can
  change display / object settings there.
+ cd. render.cpp - on_button_release_event // click only

* Multi-model selector ...
+ leave the single mode's "settings" object
+ detect changes, and show those in the existing UI
+ load and save new settings as we switch
+ prompt to save changes on selection ...

* Serial
+ libreprap:
+ don't write anything (particularly a re-send) while
a partial read is underway [?]
+ add a 'comms_debug' boolean ...
+ replace libreprap by an IOChannel

+ add a test serial connection ...
+ error dialogs - "failed to connect ?"
+ /dev/ttyUSB0 - EACCES
+ group / permissions problem.
+ you need to tweak permissions, or add yourself
to XYZ group, and re-login ...
+ connection button
+ should require confirmation before going off-line
during a print ... [ and/or 'pause printing' ]


--- older stuff ---
Something went wrong with that request. Please try again.