New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Shared address book hidden when try to sync with DAVdroid #6930

Open
wAmpIre opened this Issue Sep 25, 2018 · 7 comments

Comments

Projects
None yet
5 participants
@wAmpIre

wAmpIre commented Sep 25, 2018

I installed DAVdroid 2.0.X-ose on a new mobile phone.

DAVdroid detects shared calendars but no shared address book. As you can see at https://forums.bitfire.at/topic/1833/tine-2-0-shared-addressbook-not-discovered/4 Tine 2.0 hides them w/r/t the User-Agent.

As far as I can grep there's some DAVdroid related code in Addressbook/Convert/Contact/VCard/Factory.php and Addressbook/Convert/Contact/VCard/DavDroid.php

On another phone I upgraded DAVdroid from 1.X to 2.0.X and sync still works without any problem.

@wAmpIre wAmpIre changed the title from Shared calendars hidden when try to sync with DAVDroid to Shared calendars hidden when try to sync with DAVdroid Sep 25, 2018

@pschuele

This comment has been minimized.

Show comment
Hide comment
@pschuele

pschuele Sep 26, 2018

Member

hi,

thanks for the report.
shouldn't we rename the issue to "shared addressbook hidden ..."?

Member

pschuele commented Sep 26, 2018

hi,

thanks for the report.
shouldn't we rename the issue to "shared addressbook hidden ..."?

@wAmpIre wAmpIre changed the title from Shared calendars hidden when try to sync with DAVdroid to Shared address book hidden when try to sync with DAVdroid Sep 26, 2018

@wAmpIre

This comment has been minimized.

Show comment
Hide comment
@wAmpIre

wAmpIre Oct 4, 2018

Any news on this bug?

It's the 2nd time in ~4 month that Tine is completely unusable for me due to a bug in *DAV code :(

wAmpIre commented Oct 4, 2018

Any news on this bug?

It's the 2nd time in ~4 month that Tine is completely unusable for me due to a bug in *DAV code :(

@roadie70

This comment has been minimized.

Show comment
Hide comment
@roadie70

roadie70 Oct 4, 2018

Suffering the same problem. Would be great if this could be fixed soon.

roadie70 commented Oct 4, 2018

Suffering the same problem. Would be great if this could be fixed soon.

@PetitSumatra

This comment has been minimized.

Show comment
Hide comment
@PetitSumatra

PetitSumatra Oct 10, 2018

Ich hab das gleiche Problem nach dem Update von
Ubuntu 16.04 LTS auf Ubuntu 18.04 LTS
und dem Update von Tine auf die aktuelle Version
Davdroid - Das immer tadellos funktionierte findet jetzt keinen CalDAV Dienst mehr
Active Sync geht - aber Synchronisiert mir keine "Geteilten/Shared" Kalender
Also hab ich mir eine VM aufgesetzt mit 18.4 und wollte Tine20 (2018.08.4)
frisch - ohne Update aus dem Repository installieren.
Das Browser Setup hat nicht funktioniert.
Das Setup ging nur über CLI.
Davical findet nach wie vor keinen Dienst mehr
Thunderbird synchronisiert auch nicht mehr (Kalender ist ausgegraut)
falsche CalDAV Baseurl? -
Benutzt habe ich die CalDAV URL:
die in -> Eigenschaften vom Kalender angegeben ist.

PetitSumatra commented Oct 10, 2018

Ich hab das gleiche Problem nach dem Update von
Ubuntu 16.04 LTS auf Ubuntu 18.04 LTS
und dem Update von Tine auf die aktuelle Version
Davdroid - Das immer tadellos funktionierte findet jetzt keinen CalDAV Dienst mehr
Active Sync geht - aber Synchronisiert mir keine "Geteilten/Shared" Kalender
Also hab ich mir eine VM aufgesetzt mit 18.4 und wollte Tine20 (2018.08.4)
frisch - ohne Update aus dem Repository installieren.
Das Browser Setup hat nicht funktioniert.
Das Setup ging nur über CLI.
Davical findet nach wie vor keinen Dienst mehr
Thunderbird synchronisiert auch nicht mehr (Kalender ist ausgegraut)
falsche CalDAV Baseurl? -
Benutzt habe ich die CalDAV URL:
die in -> Eigenschaften vom Kalender angegeben ist.

@wAmpIre

This comment has been minimized.

Show comment
Hide comment
@wAmpIre

wAmpIre Oct 13, 2018

Does anyone care about this bug?!? :-/

wAmpIre commented Oct 13, 2018

Does anyone care about this bug?!? :-/

@paulmhh

This comment has been minimized.

Show comment
Hide comment
@paulmhh

paulmhh Oct 13, 2018

Contributor

wrote a test that confirms that there is a problem depending on the user agent, will fix it next week

Contributor

paulmhh commented Oct 13, 2018

wrote a test that confirms that there is a problem depending on the user agent, will fix it next week

@paulmhh

This comment has been minimized.

Show comment
Hide comment
@paulmhh

paulmhh Oct 15, 2018

Contributor

here a patch to fix it until the next release
diff.txt

this issue will be closed automatically with the next release

Contributor

paulmhh commented Oct 15, 2018

here a patch to fix it until the next release
diff.txt

this issue will be closed automatically with the next release

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment