New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

worker.php not "working" ? #6956

Open
landei16 opened this Issue Nov 6, 2018 · 7 comments

Comments

Projects
None yet
3 participants
@landei16

landei16 commented Nov 6, 2018

Hey community,

currently i´m running tine 2017.08 on my server and i´m facing issues with external invitations.
The problem is that no invitation is sent to participants not part of my tine20 group but external. Is it possible to deliver external recipients a invitation to events as well so they are able to accept?
Tine Worker is running as a service (initctl)
/usr/bin/php -d include_path=/etc/tine20 -f /var/www/mail/tine20/worker.php
Regards and thanks for you help

Ruediger

@pschuele

This comment has been minimized.

Member

pschuele commented Nov 7, 2018

hi Ruediger,

if the worker would not be working, the tine20 users would also receive no invitations.
please switch the logging to debug and have a look in the tine20 logfile. you should see the problem there. maybe a configuration problem?

@pschuele pschuele added the Calendar label Nov 7, 2018

@landei16

This comment has been minimized.

landei16 commented Nov 7, 2018

Hi pschuele,
that´s the case - even the tine20 users are not getting invitations in their mailbox but the date is filled in the calendar - anyhow - will switch to debug and check the log!

Regards
Ruediger

@pschuele

This comment has been minimized.

Member

pschuele commented Nov 7, 2018

ah ok. then there really might be a problem with the worker. maybe you could try without the actionqueue/worker and check if this works.
you can also set the worker to debug loglevel:

[general]
logfile  = /var/log/tine20-worker.log
loglevel = 7
daemonize = 1
@landei16

This comment has been minimized.

landei16 commented Nov 7, 2018

I assume this needs to be filled into worker.php - right?

@ignoreigor

This comment has been minimized.

ignoreigor commented Nov 7, 2018

Land-Ei wrote

I assume this needs to be filled into worker.php - right?

No it's not php-code. You have to fill an ini-file, the default location is /etc/tine20/actionQueue.ini

@landei16

This comment has been minimized.

landei16 commented Nov 12, 2018

Hey all,
first of all thanks for helping me very fast.
Currently i feel that the setup of worker is not correct in my installation directory of Tine20 but to be honest, there is no detailed description available what to do to get worker running. e.g. i miss /etc/tine20/actionQueue.ini file in my configuration at all!

So is there a description available how to configure tine20-worker correctly?

Thanks for your help
Landei

@pschuele

This comment has been minimized.

Member

pschuele commented Nov 13, 2018

I added a wiki page (which still needs some work) with a reference to an issue with some info on the worker setup: https://github.com/tine20/tine20/wiki/EN%3AQueue

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment