New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Active Sync stops working. (Outlook 2016 & 2019) #6968

Open
anio89 opened this Issue Nov 30, 2018 · 4 comments

Comments

Projects
None yet
3 participants
@anio89

anio89 commented Nov 30, 2018

Hello,

since some days i got some problems with a new Sync of my Outlook 2019 and 2016.

First the sync works very fine but then it stops. After this Outlook is saying, that the folder is up to date. But this is wrong, because many of my E-Mails are missing.

In the webinterface the folders are really up to date. So it seems to me, that is something wrong with my devices.

Someone got the same problem?

Thanks a lot for helping me.

@pschuele

This comment has been minimized.

Member

pschuele commented Dec 3, 2018

hi,

do you see any errors in the server logfiles?

@pschuele pschuele added the ActiveSync label Dec 3, 2018

@pschuele pschuele changed the title from Active Sync stops working. to Active Sync stops working. (Outlook 2016 & 2019) Dec 3, 2018

@anio89

This comment has been minimized.

anio89 commented Dec 4, 2018

Hey,
Thanks for helping me.

The file tine20.log only show the following things. But i can not see a failure. And the PHP Error log shows nothing.

The Only Error is shown on Apache.
=> ERROR CODE 500
=> Message:
POST /Microsoft-Server-ActiveSync?Cmd=Sync&User=example&DeviceId=50FADC93791F49458777XXXXXDDA13B&DeviceType=WindowsOutlook15 HTTP/1.0 --

This is a short extract of the tine20.log:

2018-12-04T18:48:57+00:00 WARN (4): Tinebase_Core::errorHandler::685 #0 [internal function]: Tinebase_Core::errorHandler(2, 'is_readable(): ...', '$ #1 /var/www/vhosts/example.de/tine.example.de/vendor/zendframework/zendframework1/library/Zend/Loader.php(186): is_readable('/opt/plesk/php/...') #2 /var/www/vhosts/example.de/tine.example.de/vendor/zendframework/zendframework1/library/Zend/Loader/PluginLoader.php(401): Zend_Loader::isReadable('/var/www/vhosts...') #3 /var/www/vhosts/example.de/tine.example.de/vendor/zendframework/zendframework1/library/Zend/Filter/Input.php(1189): Zend_Loader_PluginLoader->load('InArray') #4 /var/www/vhosts/example.de/tine.example.de/vendor/zendframework/zendframework1/library/Zend/Filter/Input.php(1170): Zend_Filter_Input->_getFilterOrValidator('validate', $ #5 /var/www/vhosts/example.de/tine.example.de/vendor/zendframework/zendframework1/library/Zend/Filter/Input.php(911): Zend_Filter_Input->_getValidator(Array) #6 /var/www/vhosts/example.de/tine.example.de/vendor/zendframework/zendframework1/library/Zend/Filter/Input.php(786): Zend_Filter_Input->_validate() #7 /var/www/vhosts/example.de/tine.example.de/vendor/zendframework/zendframework1/library/Zend/Filter/Input.php(442): Zend_Filter_Input->_process() #8 /var/www/vhosts/example.de/tine.example.de/Tinebase/Record/Abstract.php(576): Zend_Filter_Input->isValid() #9 /var/www/vhosts/example.de/tine.example.de/Tinebase/Backend/Sql/Abstract.php(1303): Tinebase_Record_Abstract->isValid(true) #10 /var/www/vhosts/example.de/tine.example.de/Felamimail/Controller/Folder.php(285): Tinebase_Backend_Sql_Abstract->update(Object(Felamimail_Model_Folder)) #11 /var/www/vhosts/example.de/tine.example.de/Felamimail/Controller/Cache/Message.php(995): Felamimail_Controller_Folder->update(Object(Felamimail_Model_Folder)) #12 /var/www/vhosts/example.de/tine.example.de/Felamimail/Controller/Cache/Message.php(281): Felamimail_Controller_Cache_Message->_updateFolderStatus(Object(Felamimail_Mode$ #13 /var/www/vhosts/example.de/tine.example.de/Felamimail/Frontend/Json.php(178): Felamimail_Controller_Cache_Message->updateCache('f3d0fdd5c75d877...', 10) #14 /var/www/vhosts/example.de/tine.example.de/vendor/zendframework/zendframework1/library/Zend/Server/Abstract.php(232): Felamimail_Frontend_Json->updateMessageCache('f3d0$ #15 /var/www/vhosts/example.de/tine.example.de/vendor/zendframework/zendframework1/library/Zend/Json/Server.php(590): Zend_Server_Abstract->_dispatch(Object(Zend_Server_Met$ #16 /var/www/vhosts/example.de/tine.example.de/vendor/zendframework/zendframework1/library/Zend/Json/Server.php(197): Zend_Json_Server->_handle() #17 /var/www/vhosts/example.de/tine.example.de/Tinebase/Server/Json.php(383): Zend_Json_Server->handle(Object(Zend_Json_Server_Request)) #18 /var/www/vhosts/example.de/tine.example.de/Tinebase/Server/Json.php(161): Tinebase_Server_Json->_handle(Object(Zend_Json_Server_Request)) #19 /var/www/vhosts/example.de/tine.example.de/Tinebase/Core.php(261): Tinebase_Server_Json->handle(Object(Tinebase_Http_Request)) #20 /var/www/vhosts/example.de/tine.example.de/index.php(24): Tinebase_Core::dispatchRequest() #21 {main}

@pschuele

This comment has been minimized.

Member

pschuele commented Dec 5, 2018

looks like there is a permission problem: the webserver might not be able to read all files below /var/www/vhosts/example.de/tine.example.de/. could you please check that?

@pschuele pschuele added the Webserver label Dec 5, 2018

@krie9er

This comment has been minimized.

krie9er commented Dec 9, 2018

Hi I'm working on the Server together with @anio89.

I've checked the permissions and they are set to 0644 with the right user and Group.

Curious is, that active sync works an Android and iOS devices. only MS-Outlook has a Problem.

Any other suggestions? Thanks a lot!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment