Skip to content

EN:System requirements

Johannes Nohl edited this page Mar 4, 2019 · 5 revisions

Server requirements

Generally Tine 2.0 community editions supports all officially supported PHP versions. For Database server MySQL or MariaDB is recommended. Support for others have been discontinued.

Latest Release Notes

Starting from 2019.02 some major changes regarding system requirements are to be noted. Latest Release Notes can be found in the repository. Also see section server requirements in Readme.

PHP 7.x required, older PHP versions not supported anymore

Since release 2019.02.01 community release PHP needs to be greater or equal to 7.0. Support for PHP versions up to 5.6 is not uphold. Some platforms like RHEL/CentOS 7 do not fulfill the requirements by default anymore.

Support for some Databases has been dropped

  • Support for PGSQL has been dropped
  • Support for Oracle has been dropped
  • MySQL Version needs to be greater or equal to 5.7.5
  • MariaDB Version needs to be greater or equal to 10.0.2

General

Overview

  • Webserver (e. g. Apache Webserver, Nginx,...)
  • Database server
    • MySQL 5.7.5 or later
    • MariaDB 10.0.2
  • PHP 7.0 - 7.3 suggested

PHP Extensions

Required

  • json
  • gd
  • date
  • SPL
  • SimpleXML
  • ctype
  • dom
  • openssl
  • iconv
  • zip
  • xml
  • hash
  • mbstring

Optional

  • Redis
  • LDAP
  • Memcache

For a detailed overview have a look at http://framework.zend.com/manual/1.12/en/requirements.introduction.html (but only the listed ones are required for running Tine20).

Client requirements

Supported browsers

  • Mozilla Firefox Version 38 (ESR) or later
  • Microsoft Internet Explorer 11 or later
  • Apple Safari 9 or later
  • Chrome Version 36 or later
  • Microsoft Edge 38 or later

For security reasons, we recommend always to use the latest version!

You can’t perform that action at this time.