Permalink
Fetching contributors…
Cannot retrieve contributors at this time
231 lines (230 sloc) 9.35 KB
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>com.tinkerpop.gremlin</groupId>
<artifactId>gremlin</artifactId>
<version>2.7.0-SNAPSHOT</version>
<relativePath>../pom.xml</relativePath>
</parent>
<artifactId>gremlin-groovy</artifactId>
<name>Gremlin-Groovy: Gremlin for the Groovy Language</name>
<developers>
<developer>
<name>Marko A. Rodriguez</name>
<email>marko@markorodriguez.com</email>
<url>http://markorodriguez.com</url>
</developer>
</developers>
<contributors>
<contributor>
<name>Pavel Yaskevich</name>
<email>povel.y@gmail.com</email>
<url>http://github.com/xedin</url>
</contributor>
<contributor>
<name>Darrick Wiebe</name>
<email>darrick@innatesoftware.com</email>
<url>http://github.com/pangloss</url>
</contributor>
<contributor>
<name>Peter Neubauer</name>
<email>peter.neubauer@neotechnology.com</email>
<url>http://www.linkedin.com/in/neubauer</url>
</contributor>
</contributors>
<mailingLists>
<mailingList>
<name>Gremlin Users</name>
<subscribe>http://groups.google.com/group/gremlin-users</subscribe>
<unsubscribe>http://groups.google.com/group/gremlin-users</unsubscribe>
<archive>http://groups.google.com/group/gremlin-users/topics</archive>
</mailingList>
</mailingLists>
<inceptionYear>2009</inceptionYear>
<dependencies>
<dependency>
<groupId>com.tinkerpop.gremlin</groupId>
<artifactId>gremlin-java</artifactId>
<version>${project.parent.version}</version>
</dependency>
<dependency>
<groupId>org.apache.ivy</groupId>
<artifactId>ivy</artifactId>
<version>2.3.0</version>
</dependency>
<dependency>
<groupId>com.tinkerpop</groupId>
<artifactId>pipes</artifactId>
<version>${tinkerpop.version}</version>
</dependency>
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy</artifactId>
<version>1.8.9</version>
</dependency>
<!-- included to complete the groovy dependencies so that AntBuilder can be used gremlin repl. not
clear why the groovy depenendency is not including it ... perhaps it is a provided scope -->
<dependency>
<groupId>org.apache.ant</groupId>
<artifactId>ant</artifactId>
<version>1.8.3</version>
</dependency>
<!-- PROVIDED DEPENDENCIES -->
<dependency>
<groupId>com.tinkerpop.blueprints</groupId>
<artifactId>blueprints-graph-jung</artifactId>
<version>${tinkerpop.version}</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>com.tinkerpop.blueprints</groupId>
<artifactId>blueprints-sail-graph</artifactId>
<version>${tinkerpop.version}</version>
<scope>provided</scope>
<exclusions>
<!-- conflict of jsonld via linked-data-sail via blueprints-sail-graph with blueprints-rexster-graph -->
<exclusion>
<groupId>commons-codec</groupId>
<artifactId>commons-codec</artifactId>
</exclusion>
<!-- temporary; latest Ripple no longer has its own log4j dependency -->
<exclusion>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
</exclusion>
<!-- temporary: neo4j-ha conflicts with sesame, and needs a higher version of slf4j -->
<exclusion>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-api</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>com.tinkerpop.blueprints</groupId>
<artifactId>blueprints-graph-sail</artifactId>
<version>${tinkerpop.version}</version>
<scope>provided</scope>
<exclusions>
<!-- temporary: neo4j-ha conflicts with sesame, and needs a higher version of slf4j -->
<exclusion>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-api</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>com.tinkerpop.blueprints</groupId>
<artifactId>blueprints-neo4j-graph</artifactId>
<version>${tinkerpop.version}</version>
<scope>provided</scope>
</dependency>
<!--<dependency>
<groupId>com.tinkerpop.blueprints</groupId>
<artifactId>blueprints-neo4j2-graph</artifactId>
<version>${tinkerpop.version}</version>
<scope>provided</scope>
</dependency>-->
<dependency>
<groupId>com.tinkerpop.blueprints</groupId>
<artifactId>blueprints-sparksee-graph</artifactId>
<version>${tinkerpop.version}</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>com.tinkerpop.blueprints</groupId>
<artifactId>blueprints-rexster-graph</artifactId>
<version>${tinkerpop.version}</version>
<scope>provided</scope>
</dependency>
<!-- CONSOLE -->
<dependency>
<groupId>org.fusesource.jansi</groupId>
<artifactId>jansi</artifactId>
<version>1.5</version>
</dependency>
<dependency>
<groupId>jline</groupId>
<artifactId>jline</artifactId>
<version>1.0</version>
<exclusions>
<exclusion>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
</exclusion>
</exclusions>
</dependency>
<!-- TESTING -->
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>${junit.version}</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>com.tinkerpop.gremlin</groupId>
<artifactId>gremlin-test</artifactId>
<version>${project.parent.version}</version>
<scope>test</scope>
</dependency>
</dependencies>
<build>
<directory>${basedir}/target</directory>
<finalName>${project.artifactId}-${project.version}</finalName>
<resources>
<resource>
<directory>${basedir}/src/main/resources
</directory>
</resource>
</resources>
<plugins>
<plugin>
<artifactId>maven-assembly-plugin</artifactId>
<version>2.3</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>assembly</goal>
</goals>
</execution>
</executions>
<configuration>
<attach>false</attach>
<descriptors>
<descriptor>src/assembly/standalone.xml</descriptor>
<descriptor>src/assembly/distribution.xml</descriptor>
</descriptors>
<finalName>${project.artifactId}-${project.version}</finalName>
<outputDirectory>target</outputDirectory>
<workDirectory>target/assembly/work</workDirectory>
<tarLongFileMode>warn</tarLongFileMode>
<archive>
<manifest>
<mainClass>com.tinkerpop.gremlin.groovy.console.Console</mainClass>
</manifest>
</archive>
</configuration>
</plugin>
<plugin>
<groupId>org.codehaus.gmaven</groupId>
<artifactId>gmaven-plugin</artifactId>
<version>1.4</version>
<executions>
<execution>
<goals>
<goal>generateStubs</goal>
<goal>compile</goal>
<goal>generateTestStubs</goal>
<goal>testCompile</goal>
</goals>
<configuration>
<providerSelection>1.8</providerSelection>
</configuration>
</execution>
</executions>
</plugin>
</plugins>
</build>
</project>