Skip to content
Cinch plugin for Strawpoll.
Ruby
Branch: master
Clone or download

Latest commit

Fetching latest commit…
Cannot retrieve the latest commit at this time.

Files

Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
lib/cinch/plugins
.gitattributes
.gitignore
Gemfile
LICENSE
README.md
cinch-strawpoll.gemspec

README.md

Chatrealm IRC Support tinnvec

cinch-strawpoll

Strawpoll plugin for Cinch. http://strawpoll.me

Installation

In your Gemfile

gem 'cinch-strawpoll'

Don't forget to bundle install

bundle install

Add to your bot config

require 'cinch'
require 'cinch/plugins/strawpoll'
...
bot = Cinch::Bot.new do
  configure do |c|
    ...
    c.plugins.plugins = [
      ...
      Cinch::Plugins::Strawpoll
    ]
    c.plugins.options = {
      ...
      Cinch::Plugins::Strawpoll => {
        repeat_time:    60, # Seconds to wait between poll notifications
        repeat_count:   3   # Total number of poll notifications
      }
    }
  end
end

Usage

!poll <title> | <option>, <option>

Request a strawpoll using <title> and a minimum of 2 <option> separated by commas.

Announcements will be made repeat_count times, one every repeat_time seconds.

You can’t perform that action at this time.