Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Autolink plugin appends insecure hypertext transfer protocol #4824

Closed
bpchasse opened this Issue Feb 12, 2019 · 1 comment

Comments

Projects
None yet
3 participants
@bpchasse
Copy link

bpchasse commented Feb 12, 2019

Do you want to request a feature or report a bug?
Bug
What is the current behavior?
Autolink plugin auto-appends insecure http protocol handler to links.
If the current behavior is a bug, please provide the steps to reproduce and if possible a minimal demo of the problem via fiddle.tinymce.com or similar.
paste in the following link: www.fiddle.tinymce.com - hit enter - inspect and notice the appended "http://" protocol.
What is the expected behavior?
"https://" (secure) protocol is appended by default, if no protocol is specified and link starts with "www."
Which versions of TinyMCE, and which browser / OS are affected by this issue? Did this work in previous versions of TinyMCE?
v5 , all browsers, all OSs.

@lnewson

This comment has been minimized.

Copy link
Contributor

lnewson commented Mar 1, 2019

Since this is very similar to #4825 i'm going to collapse them into the one issue to make it easier to track. The other ticket has all the details, etc... so I'll close this one as a duplicate.

@lnewson lnewson closed this Mar 1, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.