Skip to content

Cross-site scripting vulnerability in TinyMCE

lnewson published GHSA-27gm-ghr9-4v95 Jan 29, 2020
tinymce (npm composer nuget)
Affected versions
< 4.9.7, < 5.1.4
Patched versions
4.9.7, 5.1.4


A cross-site scripting (XSS) vulnerability was discovered in: the core parser, paste and visualchars plugins. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.6 or lower and TinyMCE 5.1.3 or lower.


This vulnerability has been patched in TinyMCE 4.9.7 and 5.1.4 by improved parser logic and HTML sanitization.


The workarounds available are:

  • disable the impacted plugins
  • manually sanitize the content using the BeforeSetContent event (see below)
  • upgrade to either TinyMCE 4.9.7 or TinyMCE 5.1.4

Example: Manually sanitize content

editor.on('BeforeSetContent', function(e) {
  var sanitizedContent = ...; // Manually sanitize content here
  e.content = sanitizedContent;


Tiny Technologies would like to thank Michal Bentkowski for discovering this vulnerability.


For more information

If you have any questions or comments about this advisory:

You can’t perform that action at this time.