Find file
Fetching contributors…
Cannot retrieve contributors at this time
80 lines (54 sloc) 2.91 KB
layout title

Installation supports Python 2.4 – 2.6 and has no immediate prerequisites.

  1. Stable Version
    1. From Source
      1. System-wide
      2. Local
    2. Via Distribution
      1. Debian-based
      2. Red Hat-based
  2. Development Version
  3. Verify Install

Stable Version

The easiest way to install is using easy_install.
Note that you will install the version specified in the Python Package Index.


From Source

tar xvzf


sudo python install


If you need to bundle with your application extract the source to a vendor folder and create a symlink, normally within your package's root.

ln -s vendor/ web

Via GNU/Linux Distribution

Debian or Ubuntu

If you are on a Debian-based system you can install using apt-get.
Note that you may not get the latest version as the Ubuntu/Debian release cycles are different from See Debian and Ubuntu package profiles for more information.

sudo apt-get install python-webpy

Red Hat or Fedora, RHEL, CentOS

If you are on a Red Hat-based system you can install using yum or up2date.
Note that CentOS requires the EPEL repository.

yum install python-webpy
up2date -i python-webpy

Development Branch

To follow the bleeding edge clone the master branch.

git clone git://

Verify Install

python -c "import web; web.application(('/', lambda: 'success')).run()"

Point a browser to your host at port 8080 and expect a response of success.