New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

chromecast option doesn't work with snaps #483

Open
emk2203 opened this Issue Apr 18, 2018 · 10 comments

Comments

Projects
None yet
4 participants
@emk2203
Copy link

emk2203 commented Apr 18, 2018

Description

stream to chromecast not possible with tizonia v13.0 snap on Ubuntu 18.04LTS, network with more than one chromecast

Steps to Reproduce

  1. play songs from soundcloud and youtube on local speaker, works
  2. add -c 'emk.cc.livingroom' option - tizonia shows song title and then
tizonia exiting (OMX_ErrorInsufficientResources).

 [OMX.Aratelia.audio_renderer.chromecast:port:0]
 [OMX_ErrorInsufficientResources]
  1. test with -c emk.cc.livingroom showed same behaviour

Expected behavior: music should be streamed to chromecast
Actual behaviour: tizonia aborts

Reproduces how often: 100%

Versions

$ tizonia --version
tizonia 0.13.0. Copyright (C) 2018 Juan A. Rubio
This software is part of the Tizonia project <http://tizonia.org>

$ tizonia --debug
tizonia 0.13.0. Copyright (C) 2018 Juan A. Rubio
This software is part of the Tizonia project <http://tizonia.org>

Debug Info:
	    * [Boost 1_58]
	    * [TagLib 1.9.1]
	    * [MediaInfoLib - v0.7.82]

OS: Ubuntu Bionic Beaver 18.04LTS

Installation Method Used

Snap

Additional Information

same failure when trying IP addresses instead of chromecast names

@tizonia

This comment has been minimized.

Copy link
Owner

tizonia commented Apr 18, 2018

Hi!, thanks for taking the time to report this issue.

I actually noticed this issue since right before releasing 0.13.0, but I run out of time to address it on that cycle.

I posted a question in the Snapcraft forum that relates to this problem. Here is the link for reference:
https://forum.snapcraft.io/t/tizonia-command-line-app-and-dbus-daemons-in-the-same-snap/4340

I'll see if I can get this figured out for 0.14.0, which I plan to release in the next few days. No promises though 😉

@tizonia tizonia added the bug label Apr 18, 2018

@tizonia tizonia added this to the v0.14.0 milestone Apr 18, 2018

@emk2203

This comment has been minimized.

Copy link
Author

emk2203 commented Apr 29, 2018

Unfortunately, the issue persists on 0.14.0 as well.

@tizonia

This comment has been minimized.

Copy link
Owner

tizonia commented Apr 29, 2018

Hi @emk2203 .

Yes, the issue is still there. I have not found enough time recently to get this one fixed. It needs a little bit of focus from my side and possibly another bit of nagging the guys in the snapcraft forum to get some clues/help from them.

This is high on my list, so it won't be too long until I get it figured out.

@tizonia tizonia modified the milestones: v0.14.0, v0.16.0 Jun 15, 2018

@Nojahhh

This comment has been minimized.

Copy link

Nojahhh commented Sep 29, 2018

Hi guys,

I just wanted to let you know I also experience this on my 0.15.0 installation.
Playing locally works just fine, but as soon as I'm trying to cast it I get this error.

tizonia exiting (OMX_ErrorInsufficientResources).

[OMX.Aratelia.audio_renderer.chromecast:port:0]
[OMX_ErrorInsufficientResources]

I only have 1 chromecast on my network and I can send other commands to it with pychromecast.

@tizonia

This comment has been minimized.

Copy link
Owner

tizonia commented Sep 30, 2018

Hi @Nojahhh , thanks for the interest in this issue

Have you installed Tizonia using Debian packages or the Snap?

There is an unresolved problem with the snap package. Tizonia can talk to Chromecast devices if you installed it using native Debian packages. With the snap package there is a problem where the communication between the Tizonia cmd-line app and Tizonia's D-Bus service used to communicate with Chromecast devices does not work with confinement. This is likely to be a packaging issue in Tizonia's snap.

It is just a matter of finding the time to dig into the Snapcraft forum for long enough!...

Hopefully one of these days!

@Nojahhh

This comment has been minimized.

Copy link

Nojahhh commented Oct 13, 2018

Hi, thanks for the reply!

I was uncertain on how I installed it so I did a fresh install with curl but it seems like the problem still persists. Fingers crossed that you guys find it a solution to this as it's one of the final pieces to my project! :)

@juanrubio

This comment has been minimized.

Copy link
Collaborator

juanrubio commented Oct 14, 2018

Thanks for getting back. Yes I believe your are right. There seems to be an issue also in the debian-based installation. All I can think right now is that something has changed in pychromecast that breaks tizonia somehow. I will investigate although unfortunately I can't promise a quick turnaround on this one due to my current lack of bandwidth!

@juanrubio

This comment has been minimized.

Copy link
Collaborator

juanrubio commented Nov 8, 2018

@Nojahhh

There seems to be an issue with name resolution. Have you tried providing the IP address of the Chromecast device instead of its name?

i.e.: this does not seem to work right now:

tizonia --youtube-audio-mix-search 'good life' --cast 'Chromecast-Ultra'

but this does:

tizonia --youtube-audio-mix-search 'good life' --cast '192.168.1.128'

@juanrubio juanrubio changed the title chromecast option doesn't work with v13.0 snap chromecast option doesn't work with snaps Dec 3, 2018

@tizonia tizonia removed this from the v0.16.0 milestone Dec 20, 2018

@Nojahhh

This comment has been minimized.

Copy link

Nojahhh commented Jan 7, 2019

Hey @juanrubio,

I'm sorry for such late response.
Yes, I have tried with both name and IP adress which both gives the same result.

I also reinstalled tizonia again with your curl command, to no avail :(

[OMX.Aratelia.audio_renderer.chromecast:port:0]
[OMX_ErrorInsufficientResources]

I've tried with youtube and soundcloud, same result.

@tizonia

This comment has been minimized.

Copy link
Owner

tizonia commented Jan 10, 2019

@Nojahhh

Thanks for testing those scenarios. I appreciate your help.

Please note that I have not forgotten about this issue and I will eventually get to the bottom of it. Bear with me as I'm currently busy with a couple of other issues and this should be next after those get resolved.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment