Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Linux Mint 18 Sarah: installation issue via install.sh script #508

Closed
hackertron opened this issue Aug 23, 2018 · 9 comments

Comments

Projects
None yet
3 participants
@hackertron
Copy link

commented Aug 23, 2018

Hey , i was trying to install tizonia on my Linux Mint 18 by following the instructions and i am getting following error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tizonia-all : Depends: libtizgmusic0 but it is not going to be installed
               Depends: libtizsoundcloud0 but it is not going to be installed
               Depends: libtizdirble0 but it is not going to be installed
               Depends: libtizyoutube0 but it is not going to be installed
               Depends: libtizplex0 but it is not going to be installed
               Depends: libtizchromecast0 but it is not going to be installed
               Depends: tizcastd but it is not going to be installed
               Depends: libtizchromecastrnd0 but it is not going to be installed
               Depends: libtizhttpsrc0 but it is not going to be installed
               Depends: libtizvp8dec0 but it is not going to be installed
               Depends: tizonia-player but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Oops. Something went wrong!
@tizonia

This comment has been minimized.

Copy link
Owner

commented Aug 23, 2018

Hi!
thanks for taking the time to write a report.

Strange, normally this does not happen.

Try removing all Tizonia deb packages from your system using the commands below. After that, re-run the install.sh script and if possible, copy all output here.

sudo apt-get remove --purge tizonia-all -qq --force-yes && sudo apt-get autoremove -qq --force-yes
dpkg -l | grep -E 'ii\s*(libtiz|tiz|python-tiz)' | awk '{ print $2 }' | xargs sudo apt-get remove --purge -qq
@hackertron

This comment has been minimized.

Copy link
Author

commented Aug 24, 2018

Hey , thanks for the quick reply but i am still getting same result.

@tizonia

This comment has been minimized.

Copy link
Owner

commented Aug 24, 2018

Which exact version of Linux Mint are you using? 18, 18.1, 18.2, 18.3 ?

The install script currently supports 'sarah' (18) and 'serena' (18.1) which I believe are based on Ubuntu 16.04.

elif echo "$RELIDS" | grep -E 'xenial|loki|sarah|serena'; then
  # NOTE: Elementary OS 'loki' is based on xenial
  # Linux Mint 'sarah' and 'serena' are based on xenial
  DISTRO="ubuntu" ; RELEASE="xenial"

It would also be possible to install Tizonia on Sonya (18.2) and Sylvia (18.3) if these are also based on 16.04, by simply adding their names in the above section of the install.sh script.

Alternatively, are you able to copy the output of the script (all of it, from start)?

@tizonia

This comment has been minimized.

Copy link
Owner

commented Aug 24, 2018

Linux Mint Sonya and Sylvia are now recognized as Xenial derivatives in install.sh:
414d4c6

@hackertron

This comment has been minimized.

Copy link
Author

commented Aug 24, 2018

I am using Linux Mint 18 Sarah , so i guess it is xenial

@hackertron

This comment has been minimized.

Copy link
Author

commented Aug 24, 2018

here is the script output

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   150  100   150    0     0     76      0  0:00:01  0:00:01 --:--:--    76
100  4343  100  4343    0     0   1397      0  0:00:03  0:00:03 --:--:--  5015
cat: /etc/upstream-release: Is a directory
DISTRIB_CODENAME=sarah
[sudo] password for nightmare: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libffi-dev is already the newest version (3.2.1-4).
apt-transport-https is already the newest version (1.2.27).
curl is already the newest version (7.47.0-1ubuntu2.8).
libssl-dev is already the newest version (1.0.2g-1ubuntu4.13).
libxml2-dev is already the newest version (2.9.3+dfsg1-1ubuntu0.6).
libxslt1-dev is already the newest version (1.1.28-2.1ubuntu0.1).
python-dev is already the newest version (2.7.12-1~16.04).
0 upgraded, 0 newly installed, 0 to remove and 300 not upgraded.
Ign:1 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 InRelease
Get:2 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 Release [3457 B]                      
Get:3 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 Release.gpg [801 B]                   
Ign:3 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 Release.gpg                           
Hit:4 https://deb.nodesource.com/node_6.x xenial InRelease                                            
Get:5 https://cli-assets.heroku.com/branches/stable/apt ./ InRelease [2533 B]                         
Ign:5 https://cli-assets.heroku.com/branches/stable/apt ./ InRelease                                  
Hit:6 http://archive.canonical.com/ubuntu xenial InRelease                                            
Get:7 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]                            
Hit:8 https://repo.skype.com/deb stable InRelease                                                     
Hit:9 http://archive.ubuntu.com/ubuntu xenial InRelease                                               
Hit:10 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4/multiverse amd64 Packages            
Ign:11 http://packages.linuxmint.com sarah InRelease                                                  
Get:12 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]                             
Hit:13 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4/multiverse arm64 Packages            
Hit:15 http://packages.linuxmint.com sarah Release                                                    
Ign:17 http://dl.google.com/linux/chrome/deb stable InRelease                                         
Hit:18 https://download.sublimetext.com apt/stable/ InRelease                                         
Hit:19 https://apt.llvm.org/xenial llvm-toolchain-xenial-3.9 InRelease                                
Ign:20 https://dl.bintray.com/tizonia/ubuntu trusty InRelease                                         
Ign:21 https://dl.bintray.com/tizonia/ubuntu {distribution} InRelease                     
Hit:22 http://dl.google.com/linux/chrome/deb stable Release                               
Ign:14 http://apt.mopidy.com stable InRelease                                                         
Get:24 https://dl.bintray.com/tizonia/ubuntu trusty Release [2689 B]                   
Hit:24 https://dl.bintray.com/tizonia/ubuntu trusty Release                                           
Hit:27 http://archive.ubuntu.com/ubuntu xenial-backports InRelease                                    
Hit:26 http://apt.mopidy.com stable Release                    
Get:28 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [838 kB]  
Hit:30 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease                
Ign:31 https://dl.bintray.com/tizonia/ubuntu {distribution} Release                            
Ign:32 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} amd64 Packages
Ign:33 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} i386 Packages
Ign:34 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} all Packages
Ign:35 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} Translation-en
Ign:32 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} amd64 Packages
Hit:36 http://ppa.launchpad.net/dawidd0811/neofetch/ubuntu xenial InRelease
Ign:33 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} i386 Packages                
Hit:37 http://ppa.launchpad.net/linuxgndu/sqlitebrowser/ubuntu xenial InRelease    
Ign:34 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} all Packages                 
Hit:38 http://ppa.launchpad.net/neurobin/ppa/ubuntu xenial InRelease                                  
Ign:35 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} Translation-en               
Hit:39 http://ppa.launchpad.net/noobslab/apps/ubuntu xenial InRelease                                 
Ign:32 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} amd64 Packages               
Ign:33 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} i386 Packages                
Ign:34 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} all Packages                 
Ign:35 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} Translation-en               
Hit:40 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu xenial InRelease                         
Hit:41 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu xenial InRelease                         
Ign:32 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} amd64 Packages               
Get:42 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [757 kB]                    
Ign:33 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} i386 Packages                
Ign:34 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} all Packages                 
Ign:35 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} Translation-en               
Ign:32 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} amd64 Packages               
Ign:33 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} i386 Packages                
Ign:34 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} all Packages                 
Ign:35 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} Translation-en               
Err:32 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} amd64 Packages               
  404  Not Found
Ign:33 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} i386 Packages                
Ign:34 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} all Packages                 
Ign:35 https://dl.bintray.com/tizonia/ubuntu {distribution}/{components} Translation-en               
Get:43 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [678 kB]               
Get:44 http://archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [619 kB]                
Fetched 3115 kB in 18s (165 kB/s)                                                                     
Reading package lists... Done
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:4
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:4
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:4
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:4
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/additional-repositories.list:2
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/additional-repositories.list:2
W: GPG error: http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 Release: The following signatures were invalid: KEYEXPIRED 1515625755
W: The repository 'http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: https://cli-assets.heroku.com/branches/stable/apt ./ InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C927EBE00F1B0520
W: The repository 'https://cli-assets.heroku.com/branches/stable/apt ./ InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'https://dl.bintray.com/tizonia/ubuntu {distribution} Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://dl.bintray.com/tizonia/ubuntu/dists/{distribution}/{components}/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:4
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:4
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:4
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:4
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/additional-repositories.list:2
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/additional-repositories.list:2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-pip is already the newest version (8.1.1-2ubuntu0.4).
0 upgraded, 0 newly installed, 0 to remove and 300 not upgraded.
/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.
  warnings.warn(warning, RequestsDependencyWarning)
Collecting gmusicapi
Requirement already up-to-date: soundcloud in /usr/local/lib/python2.7/dist-packages (0.5.0)
Collecting youtube-dl
  Using cached https://files.pythonhosted.org/packages/0c/47/da1b2ce86420312d01dbe2e2362e6491fe2bbac21efb2418729cf72afa42/youtube_dl-2018.8.22-py2.py3-none-any.whl
Requirement already up-to-date: pafy in /usr/local/lib/python2.7/dist-packages (0.5.4)
Requirement already up-to-date: pycountry in /usr/local/lib/python2.7/dist-packages (18.5.26)
Requirement already up-to-date: titlecase in /usr/local/lib/python2.7/dist-packages (0.12.0)
Requirement already up-to-date: pychromecast in /usr/local/lib/python2.7/dist-packages (2.2.0)
Requirement already up-to-date: plexapi in /usr/local/lib/python2.7/dist-packages (3.0.6)
Collecting fuzzywuzzy
  Using cached https://files.pythonhosted.org/packages/d8/f1/5a267addb30ab7eaa1beab2b9323073815da4551076554ecc890a3595ec9/fuzzywuzzy-0.17.0-py2.py3-none-any.whl
Requirement already up-to-date: eventlet in /usr/local/lib/python2.7/dist-packages (0.24.1)
Requirement already satisfied, skipping upgrade: six>=1.9.0 in /usr/lib/python2.7/dist-packages (from gmusicapi) (1.10.0)
Requirement already satisfied, skipping upgrade: appdirs>=1.1.0 in /usr/local/lib/python2.7/dist-packages (from gmusicapi) (1.4.0)
Requirement already satisfied, skipping upgrade: MechanicalSoup>=0.4.0 in /usr/local/lib/python2.7/dist-packages (from gmusicapi) (0.10.0)
Requirement already satisfied, skipping upgrade: gpsoauth>=0.2.0 in /usr/local/lib/python2.7/dist-packages (from gmusicapi) (0.4.1)
Requirement already satisfied, skipping upgrade: oauth2client>=1.1 in /usr/lib/python2.7/dist-packages (from gmusicapi) (2.0.1)
Requirement already satisfied, skipping upgrade: decorator>=3.3.1 in /usr/local/lib/python2.7/dist-packages (from gmusicapi) (4.1.2)
Requirement already satisfied, skipping upgrade: protobuf>=3.0.0 in /usr/local/lib/python2.7/dist-packages (from gmusicapi) (3.6.0)
Requirement already satisfied, skipping upgrade: mock>=0.7.0 in /usr/lib/python2.7/dist-packages (from gmusicapi) (1.3.0)
Requirement already satisfied, skipping upgrade: future in /usr/local/lib/python2.7/dist-packages/future-0.15.2-py2.7.egg (from gmusicapi) (0.15.2)
Requirement already satisfied, skipping upgrade: python-dateutil!=2.0,>=1.3 in /usr/local/lib/python2.7/dist-packages (from gmusicapi) (2.6.0)
Requirement already satisfied, skipping upgrade: validictory!=0.9.2,>=0.8.0 in /usr/lib/python2.7/dist-packages (from gmusicapi) (0.8.3)
Collecting mutagen>=1.34 (from gmusicapi)
Collecting proboscis>=1.2.5.1 (from gmusicapi)
Requirement already satisfied, skipping upgrade: requests!=1.2.0,!=2.12.0,!=2.12.1,!=2.12.2,!=2.18.2,!=2.2.1,!=2.8.0,!=2.8.1,>=1.1.0 in /usr/local/lib/python2.7/dist-packages/requests-2.13.0-py2.7.egg (from gmusicapi) (2.13.0)
Requirement already satisfied, skipping upgrade: fudge>=1.0.3 in /usr/local/lib/python2.7/dist-packages (from soundcloud) (1.1.1)
Requirement already satisfied, skipping upgrade: simplejson>=2.0 in /usr/local/lib/python2.7/dist-packages (from soundcloud) (3.16.0)
Requirement already satisfied, skipping upgrade: zeroconf>=0.17.7 in /usr/local/lib/python2.7/dist-packages (from pychromecast) (0.20.0)
Requirement already satisfied, skipping upgrade: websocket-client in /usr/lib/python2.7/dist-packages (from plexapi) (0.18.0)
Requirement already satisfied, skipping upgrade: tqdm in /usr/local/lib/python2.7/dist-packages (from plexapi) (4.24.0)
Requirement already satisfied, skipping upgrade: enum34; python_version < "3.4" in /usr/lib/python2.7/dist-packages (from eventlet) (1.1.2)
Requirement already satisfied, skipping upgrade: dnspython>=1.15.0 in /usr/local/lib/python2.7/dist-packages (from eventlet) (1.15.0)
Requirement already satisfied, skipping upgrade: greenlet>=0.3 in /usr/local/lib/python2.7/dist-packages (from eventlet) (0.4.12)
Requirement already satisfied, skipping upgrade: monotonic>=1.4 in /usr/local/lib/python2.7/dist-packages (from eventlet) (1.5)
Requirement already satisfied, skipping upgrade: lxml in /usr/lib/python2.7/dist-packages (from MechanicalSoup>=0.4.0->gmusicapi) (3.5.0)
Requirement already satisfied, skipping upgrade: beautifulsoup4 in /usr/local/lib/python2.7/dist-packages (from MechanicalSoup>=0.4.0->gmusicapi) (4.6.0)
Requirement already satisfied, skipping upgrade: pycryptodomex>=3.0 in /usr/local/lib/python2.7/dist-packages (from gpsoauth>=0.2.0->gmusicapi) (3.6.5)
Requirement already satisfied, skipping upgrade: httplib2>=0.9.1 in /usr/lib/python2.7/dist-packages (from oauth2client>=1.1->gmusicapi) (0.9.1)
Requirement already satisfied, skipping upgrade: pyasn1>=0.1.7 in /usr/lib/python2.7/dist-packages (from oauth2client>=1.1->gmusicapi) (0.1.9)
Requirement already satisfied, skipping upgrade: pyasn1-modules>=0.0.5 in /usr/lib/python2.7/dist-packages (from oauth2client>=1.1->gmusicapi) (0.0.7)
Requirement already satisfied, skipping upgrade: rsa>=3.1.4 in /usr/lib/python2.7/dist-packages (from oauth2client>=1.1->gmusicapi) (3.2.3)
Requirement already satisfied, skipping upgrade: setuptools in /usr/local/lib/python2.7/dist-packages (from protobuf>=3.0.0->gmusicapi) (36.4.0)
Requirement already satisfied, skipping upgrade: funcsigs in /usr/lib/python2.7/dist-packages (from mock>=0.7.0->gmusicapi) (0.4)
Requirement already satisfied, skipping upgrade: pbr>=0.11 in /usr/lib/python2.7/dist-packages (from mock>=0.7.0->gmusicapi) (1.8.0)
Requirement already satisfied, skipping upgrade: netifaces!=0.10.5 in /usr/lib/python2.7/dist-packages (from zeroconf>=0.17.7->pychromecast) (0.10.4)
Requirement already satisfied, skipping upgrade: backports.ssl_match_hostname in /usr/lib/python2.7/dist-packages (from websocket-client->plexapi) (3.4.0.2)
Installing collected packages: mutagen, proboscis, gmusicapi, youtube-dl, fuzzywuzzy
  Found existing installation: mutagen 1.31
Cannot uninstall 'mutagen'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tizonia-all : Depends: libtizgmusic0 but it is not going to be installed
               Depends: libtizsoundcloud0 but it is not going to be installed
               Depends: libtizdirble0 but it is not going to be installed
               Depends: libtizyoutube0 but it is not going to be installed
               Depends: libtizplex0 but it is not going to be installed
               Depends: libtizchromecast0 but it is not going to be installed
               Depends: tizcastd but it is not going to be installed
               Depends: libtizchromecastrnd0 but it is not going to be installed
               Depends: libtizhttpsrc0 but it is not going to be installed
               Depends: libtizvp8dec0 but it is not going to be installed
               Depends: tizonia-player but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Oops. Something went wrong!

@tizonia tizonia assigned juanrubio and tizonia and unassigned juanrubio Aug 24, 2018

@tizonia tizonia added the bug label Aug 24, 2018

@tizonia tizonia added this to the v0.16.0 milestone Aug 24, 2018

@tizonia tizonia changed the title installation issue via script Linux Mint 18 Sarah: installation issue via install.sh script Aug 24, 2018

@tizonia

This comment has been minimized.

Copy link
Owner

commented Aug 24, 2018

All right, I know what's happening.

elif echo "$RELIDS" | grep -E 'trusty|freya|qiana|rebecca|rafaela|rosa|sarah'; then
  # NOTE: Elementary OS 'freya' is based on trusty
  # NOTE: LinuxMint 'qiana' 'rebecca' 'rafaela' 'rosa' 'sarah' are all based on trusty

The script was assuming 'sarah' was based on trusty. This bug is now corrected in dd1b297.

You need to do a couple of things:

  • First, remove this line that has been added to your /etc/apt/sources.list (using your favorite editor)
deb https://dl.bintray.com/tizonia/ubuntu trusty main
  • After that, re-run the curl one-liner that downloads and executes the latest version of install.sh. This time I believe will work fine.

Let me know how it goes.

@hackertron

This comment has been minimized.

Copy link
Author

commented Aug 24, 2018

Alright it worked 💯 . It was trusyt and xenial issue like you said :D .

Thanks !!

@tizonia

This comment has been minimized.

Copy link
Owner

commented Aug 26, 2018

Great!, I'm glad it worked.

Thanks again for getting in touch about this issue.

@tizonia tizonia closed this Aug 26, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.