Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

93 lines (55 sloc) 2.38 kB

2.4.4 / 2009-01-15

  • Fixed bug which was not allowing multi-word commands to view help

2.4.3 / 2009-01-15

  • Fixed bug in command_name_from_args, preventing multi-word commands

2.4.2 / 2009-01-12

  • Github! build me!

2.4.1 / 2009-01-11

  • Added ask_for_CLASS, which may be any class name such as ask_for_date, ask_for_array, etc

  • Changed doc to *.rdoc for pretty markup on github

2.3.0 / 2008-12-16

  • Removed input, output in favour of HighLines $terminal

  • Autoloading terminal formatter since it may not always be used

  • Added wrapping of text with 10 padding, defaults to 80

  • Added friendly interruption message by default, overridable with trap or int_message

  • Fixed description now showing as summary when no summary is available

2.2.1 / 2008-12-09

  • Fixed typo in String#tokenize, preventing progress bar from working

  • Fixed some small formatting issues with help output

2.2.0 / 2008-12-09

  • Additional documentation

  • Added support for arbitrary help 'blocks' using program :help, 'Your block', 'Your blocks contents'

  • Added support for description, summary, short_description, and large_description, which are displaying conditionally within help docs

  • Allowing uncaught exceptions to reach stderr, for debugging purposes

2.1.1 / 2008-12-01

  • Changed #password, now requires that the user must enter a non-empty? value

2.1.0 / 2008-12-01

  • Added progress bar

  • Added auto-inclusion of FileUtils module

  • Added stdout logging method

  • Fixed issue with options placed before sub-command

2.0.1 / 2008-11-24

  • Fixed new line after command options

  • Fixed padding for command list

2.0.0 / 2008-11-24

  • Rewrite of entire gem

  • Added auto-parsing and struct population of options

  • Added better documentation

1.2.2 / 2008-11-06

  • Forgot to add array.rb

1.2.0 / 2008-11-06

  • Added paging ability (similar to 'less')

  • Added coloring to default help generator

1.1.0 / 2008-11-06

  • Added dependency for Highline gem, which replaces Commander's user interaction lib

1.0.4 / 2008-11-04

  • Added support for –help and –version flags

1.0.3 / 2008-11-01

  • Typo causing the gem to fail build on github

1.0.2 / 2008-11-01

  • Added gemspec for github

1.0.1 / 2008-10-31

  • Added shebang line to commander init

  • Added require 'rubygems'

1.0.0 / 2008-10-31

  • Initial release

Jump to Line
Something went wrong with that request. Please try again.