Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Update Redis Dependency to 0.8 #68

Closed
wants to merge 1 commit into from

8 participants

@Radagaisus

Hi,

The revert to node_redis 0.7.x is no longer needed, 0.8.2 works fine.

@Radagaisus Radagaisus Update Redis Dependency to 0.8
Hi,

The revert to `node_redis` 0.7.x is no longer needed, [0.8.2 works fine](https://github.com/mranney/node_redis/blob/master/changelog.md).
596fe7e
@tj
Owner
tj commented

my issue of the broken parser is still open, I dont have time to try it again and see if it breaks ATM

@skeggse skeggse referenced this pull request
Closed

Update package.json #76

@skeggse

I can't find your broken parser issue. Has it been resolved? npm is letting me know about the conflicting redis versions, so I'm wondering if this could be applied.

WARN unmet dependency /{REDACTED}/node_modules/connect-redis requires redis@'0.7.3' but will load
WARN unmet dependency /{REDACTED}/node_modules/redis,
WARN unmet dependency which is version 0.8.3

Given that it's been working fine, I assume redis 0.8.3 works for connect-redis.

@migounette

In order to simplify the forest of dependencies, can you investigate the move to redis 0.8.2 (it works fine on my side).

Moreover, use ~0.8.2 rather than a fixed version (0.8.2), which helps to follow any potential changes.
Express will follow the move thanks to the dependency "*" placed on redis-connect.

If you produce a version 1.4.6, all component will be happy. I don't understand the ATM issue, if you have one I may look at it.

@skeggse

Given that node_redis follows the appropriate versioning guidelines, the wildcard version 0.8.x which specifies a variable patch version should be sufficient.

I don't understand the ATM issue, if you have one I may look at it.

Are you interpreting ATM as "Automated Teller Machine," or am I misinterpreting your comment? @visionmedia means atm as in "at the moment."

@migounette

The usage of 0.8.x is fine for me too.... I use ~0.8.2 in order to inform that that I used 0.8.2 and it works, and it should work with 0.8.x.

"my issue of the broken parser is still open, I dont have time to try it again and see if it breaks ATM"
--> I was referencing the visionmedia's thread

For your information, I run the test.js and it works fine under Linux with 0.8.x but not under Windows (Stream close issue). But I have the same issue with 0.7.x.

The problem is that the Windows version of redis is a fork of the official redis. I would look at it later (not my main target)

I am currently using v0.10.2 of nodejs.

@Mamsaac

Was there ever a merge with this commit? 0.8.3 still throws a warning about the version not being the recommended one. Plus, the package.json on 1.4.5 still shows 0.7.x, but that version is pretty old.

@mike-lang

@visionmedia Were either of these the issue you're referring to?

mranney/node_redis#425
mranney/node_redis#316

Perhaps its safe to upgrade now?

@jcrugzz

@visionmedia would be super helpful to get this merged, I've ran into issues with 0.7.x causing failures but passing in a 0.8.x redis client fixed the issue.

@chirag04
Collaborator

will update to 0.9 soon.

@chirag04 chirag04 closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jan 12, 2013
  1. @Radagaisus

    Update Redis Dependency to 0.8

    Radagaisus authored
    Hi,
    
    The revert to `node_redis` 0.7.x is no longer needed, [0.8.2 works fine](https://github.com/mranney/node_redis/blob/master/changelog.md).
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  package.json
View
2  package.json
@@ -4,7 +4,7 @@
"version": "1.4.5",
"author": "TJ Holowaychuk <tj@vision-media.ca>",
"main": "./index.js",
- "dependencies": { "redis": "0.7.x", "debug": "*" },
+ "dependencies": { "redis": "0.8.x", "debug": "*" },
"devDependencies": { "connect": "*" },
"engines": { "node": "*" }
}
Something went wrong with that request. Please try again.