Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Set libzmq ABI version to 3

libzmq master (3.1) is not ABI compatible with libzmq 2.1.x or 3.0 (removed
functionality), hence the ABI version needs to be set to 3.

Signed-off-by: Martin Lucina <martin@lucina.net>
  • Loading branch information...
commit 27524908c17b7db965f8aaa2bde513643378e372 1 parent c79abee
@mato mato authored sustrik committed
Showing with 5 additions and 3 deletions.
  1. +5 −3 configure.in
View
8 configure.in
@@ -25,11 +25,13 @@ AC_SUBST(PACKAGE_VERSION)
#
# Changes:
#
-# ZeroMQ versions prior to 2.1.0 use 0.0.0 ("unstable")
-# ZeroMQ version 2.1.0: 1:0:0
+# ZeroMQ versions prior to 2.1.0 use 0:0:0 (undefined)
+# ZeroMQ versions 2.1.x: 1:0:0 (ABI version 1)
+# ZeroMQ version 3.0: 2:0:0 (ABI version 2)
+# ZeroMQ version 3.1: 3:0:0 (ABI version 3)
#
# libzmq -version-info current:revision:age
-LTVER="1:0:0"
+LTVER="3:0:0"
AC_SUBST(LTVER)
# Take a copy of original flags
Please sign in to comment.
Something went wrong with that request. Please try again.