Permalink
Browse files

Fixes Gemfile for Travis CI

  • Loading branch information...
1 parent cfa5569 commit 665917d70612374df8bcf51c857a0b8ba9c7f95e @stephenmckinney stephenmckinney committed Jan 27, 2013
Showing with 10 additions and 6 deletions.
  1. +9 −0 Gemfile
  2. +1 −6 pomo.gemspec
View
@@ -1,4 +1,13 @@
source 'https://rubygems.org'
+gem 'rake'
+gem 'yard'
+
+group :test do
+ gem 'aruba', '~> 0.5.1'
+ gem 'rspec', '~> 2.12'
+ gem 'fakefs', '~> 0.4'
+end
+
# Specify your gem's dependencies in pomo.gemspec
gemspec
View
@@ -19,16 +19,11 @@ Gem::Specification.new do |spec|
spec.executables = spec.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
spec.test_files = spec.files.grep(%r{^(test|spec|features)/})
spec.require_paths = ['lib']
- spec.rdoc_options = ['--line-numbers', '--inline-source', '--title', 'Pomo', '--main', 'Readme.md']
+ spec.rdoc_options = ['--line-numbers', '--inline-source', '--title', 'Pomo', '--main', 'README.md']
spec.add_dependency('commander', '~> 4.1')
spec.add_dependency('octokit', '~> 1.19')
spec.add_dependency('terminal-notifier', '~> 1.4') if Pomo::OS.mac?
spec.add_dependency('growl', '~> 1.0') if Pomo::OS.mac? || Pomo::OS.windows?
spec.add_dependency('libnotify', '~> 0.8') if Pomo::OS.linux?
-
- spec.add_development_dependency('aruba', '~> 0.5.1')
- spec.add_development_dependency('rspec', '~> 2.12')
- spec.add_development_dependency('fakefs', '~> 0.4')
- spec.add_development_dependency('yard')
end

0 comments on commit 665917d

Please sign in to comment.