Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Support for .NET 4.0 #46

Closed
waynebloss opened this Issue Apr 29, 2013 · 12 comments

Comments

Projects
None yet
7 participants

Is support for .NET 4.0:

  • feasible?
  • planned?

Just curious. In any case, edge is fantastic.

Owner

tjanczuk commented Apr 29, 2013

Support for .NET 4.0 is very much feasible but currently not planned. Given that all .NET code that node.js interacts with through edge.js must be async, lack of the async/await construct in 4.0 compared to 4.5 would be major usability disadvantage.

What is your scenario that requires 4.0?

Let's keep this issue around to see how many people care about 4.0 support.

Collaborator

glennblock commented Apr 29, 2013

Task is available in 4.0. Async/Await actually also is available through
the async CTP. http://www.microsoft.com/en-us/download/details.aspx?id=9983

On Sun, Apr 28, 2013 at 9:18 PM, Tomasz Janczuk notifications@github.comwrote:

Support for .NET 4.0 is very much feasible but currently not planned.
Given that all .NET code that node.js interacts with through edge.js must
be async, lack of the async/await construct in 4.0 compared to 4.5 would be
major usability disadvantage.

What is your scenario that requires 4.0?

Let's keep this issue around to see how many people care about 4.0
support.


Reply to this email directly or view it on GitHubhttps://github.com/tjanczuk/edge/issues/46#issuecomment-17149577
.

Collaborator

glennblock commented Apr 29, 2013

Aaaah cool!

Owner

tjanczuk commented Apr 29, 2013

Once you are in the abstraction class of requiring additional software packages to be installed beyond the raw .NET framework, you can as well require .NET framework 4.5 to be installed. So this really boils down to what actual scenario would be enabled by supporting .NET 4.0 + extras which cannot be satisfied with .NET 4.5.

Contributor

paulcbetts commented Apr 29, 2013

Once you are in the abstraction class of requiring additional software packages to be installed beyond the raw .NET framework, you can as well require .NET framework 4.5 to be installed.

I'm not sure I agree with this, but what I do agree with is that Microsoft.Bcl.Async most likely doesn't work with C++/CLI DLLs, so this is probably a non-starter. Right, @dsplaisted?

Microsoft.Bcl.Async doesn't need to be installed on the machine, it can be included along with your app or library. However, unfortunately it doesn't work with C++/CLI DLLs. There's a connect issue for this here.

I happen to be building desktop apps with Node and .NET. So that is my primary scenario for caring about what version of .NET is required. Ideally I'd like to see .NET 2.0+ supported but I limited the questions to .NET 4.0 since that is the cut-off for Windows XP and I didn't want to conflate the issues.

Contributor

paulcbetts commented Apr 30, 2013

@waynebloss Just wait for #3 and use Mono everywhere

Owner

tjanczuk commented May 2, 2014

I don't think I want to enable 4.0 support. Given the code base has been effectively forked to support Mono, this would introduce another versioning dimension. The benefit does not justify the maintenance cost in my mind.

@tjanczuk tjanczuk closed this May 2, 2014

Thanks for letting me know. It's a good decision.

Hi everyone. Anybody run edge using mono on windows xp? I trying running on windows xp, but edge using .net auto on windows. even compiling "EdgeCompiler" on mono did not help. It's possible?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment