Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

deprecated dynamic property warning #5

Closed
dstine opened this Issue · 1 comment

2 participants

@dstine

When using gradle-liquibase-plugin 0.6.1 with Gradle 1.2, we receive the following warning:

Dynamic properties are deprecated: http://gradle.org/docs/current/dsl/org.gradle.api.plugins.ExtraPropertiesExtension.html
Deprecated dynamic property: "args" on "task ':updateCount'", value: "[null]".

As you know, the deprecation warning mechanism itself was introduced by Gradle prior to its 1.0 release. And the warning in this project signifies a possible bug. The warning/bug was fixed by commit
03072b7 of this project, but has not yet been released.

@stevesaliman stevesaliman was assigned
@stevesaliman
Collaborator

The code that was causing the deprecation warnings has been fixed. Version 1.0.0 of the plugin code works in without warnings in Gradle 1.x, and continues to work in Gradle 2.0

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.