Permalink
Browse files

explicitly require postgres adapter (fixes combustion issues)

  • Loading branch information...
fschwahn committed Jan 26, 2012
1 parent beef7bd commit 3160e2eabe2c1260f5dd6f801e7790deffb5a505
Showing with 3 additions and 3 deletions.
  1. +0 −2 Gemfile
  2. +2 −0 lib/activerecord-postgres-array/activerecord.rb
  3. +1 −1 spec/integration_spec.rb
View
@@ -1,5 +1,3 @@
source :rubygems
gemspec
-# fix for failing tests with combustion 0.3.1 and rails 3.2.0
-gem "rails", "~> 3.1.0"
@@ -1,3 +1,5 @@
+require 'active_record/connection_adapters/postgresql_adapter'
+
module ActiveRecord
class ArrayTypeMismatch < ActiveRecord::ActiveRecordError
end
View
@@ -37,7 +37,7 @@
article.languages.should == ["\\","\""]
end
end
-
+
describe ".update" do
before(:each) do
@article = Article.create

0 comments on commit 3160e2e

Please sign in to comment.