Skip to content
Permalink
Browse files

Apply Checker Framework Gradle plugin

org.checkerframework.javacutil.UserError: The Checker Framework must be run under JDK 1.8.  You are using version 12,000000.
  • Loading branch information...
tlinkowski committed Aug 17, 2019
1 parent 36d6b89 commit ac9439ab9925c4577607979cc99d9a9426c36a3f
Showing with 8 additions and 0 deletions.
  1. +8 −0 subprojects/sample-java-usage/sample-java-usage.gradle.kts
@@ -16,6 +16,14 @@
* limitations under the License.
*/

plugins {
id("org.checkerframework") version "0.3.22"
}

checkerFramework {
checkers = listOf("org.checkerframework.checker.nullness.NullnessChecker")
}

config {
publishing.enabled = false
}

0 comments on commit ac9439a

Please sign in to comment.
You can’t perform that action at this time.