Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
A node command that checks WordPress for core file modifications
JavaScript Shell
branch: master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
bin
lib
.gitignore
README.md
package.json

README.md

Detect WordPress Core Modifications

This is a simple node command that checks a WordPress installation for modified and/or removed files. Modifying core WordPress files is a quick way to introduce security vulnerabilities, break your site, and break future updates.

Install via npm

  1. Make sure you have node and npm installed.
  2. Install the detect-wp-core-modifications npm package with the following shell command:
npm install -g detect-wp-core-modifications

Usage

You can run the command without any arguments from within the root of a WordPress installation with the following shell command:

detect-wp-core-modifications

You can also specify a relative or absolute path to a WordPress installation:

detect-wp-core-modifications ../wordpress
Something went wrong with that request. Please try again.