Permalink
Browse files

Added local patch which causes the osm rails app to fail to build

  • Loading branch information...
tlpinney committed Feb 27, 2012
1 parent 114f2ab commit 3e3026c001b6ab864c4ea3d3d0e6734d18ddcbbb
Showing with 193 additions and 1 deletion.
  1. +11 −1 manifests/base.pp
  2. +182 −0 patches/Gemfile.lock
View
@@ -107,7 +107,7 @@
service { "apache2":
enable => true,
ensure => running,
- subscribe => [ File["/etc/apache2/conf.d/passenger"], File["/etc/apache2/sites-available/default"], Package["apache2"] ],
+ subscribe => [ Package["apache2"] ],
}
@@ -120,6 +120,16 @@
require => [Package["git-core"]],
}
+# apply local patches
+file { "/home/vagrant/openstreetmap-website/Gemfile.lock":
+ owner => vagrant,
+ group => vagrant,
+ source => "/vagrant/patches/Gemfile.lock",
+ mode => 644,
+ require => [Exec["osm_git"]],
+}
+
+
View
@@ -0,0 +1,182 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ SystemTimer (1.2.3)
+ actionmailer (3.2.1)
+ actionpack (= 3.2.1)
+ mail (~> 2.4.0)
+ actionpack (3.2.1)
+ activemodel (= 3.2.1)
+ activesupport (= 3.2.1)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ journey (~> 1.0.1)
+ rack (~> 1.4.0)
+ rack-cache (~> 1.1)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.1.2)
+ activemodel (3.2.1)
+ activesupport (= 3.2.1)
+ builder (~> 3.0.0)
+ activerecord (3.2.1)
+ activemodel (= 3.2.1)
+ activesupport (= 3.2.1)
+ arel (~> 3.0.0)
+ tzinfo (~> 0.3.29)
+ activeresource (3.2.1)
+ activemodel (= 3.2.1)
+ activesupport (= 3.2.1)
+ activesupport (3.2.1)
+ i18n (~> 0.6)
+ multi_json (~> 1.0)
+ addressable (2.2.7)
+ arel (3.0.2)
+ builder (3.0.0)
+ cocaine (0.2.1)
+ coffee-rails (3.2.2)
+ coffee-script (>= 2.2.0)
+ railties (~> 3.2.0)
+ coffee-script (2.2.0)
+ coffee-script-source
+ execjs
+ coffee-script-source (1.2.0)
+ composite_primary_keys (5.0.1)
+ activerecord (~> 3.2.0)
+ deadlock_retry (1.2.0)
+ dynamic_form (1.1.4)
+ erubis (2.7.0)
+ execjs (1.3.0)
+ multi_json (~> 1.0)
+ faraday (0.7.6)
+ addressable (~> 2.2)
+ multipart-post (~> 1.1)
+ rack (~> 1.1)
+ hike (1.2.1)
+ http_accept_language (1.0.2)
+ httpclient (2.2.4)
+ i18n (0.6.0)
+ i18n-js (2.1.2)
+ i18n
+ iconv (0.1)
+ journey (1.0.3)
+ jquery-rails (2.0.0)
+ railties (>= 3.2.0.beta, < 5.0)
+ thor (~> 0.14)
+ json (1.6.5)
+ libv8 (3.3.10.4)
+ libxml-ruby (2.2.2)
+ mail (2.4.1)
+ i18n (>= 0.4.0)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
+ memcached (1.4.1)
+ mime-types (1.17.2)
+ multi_json (1.1.0)
+ multipart-post (1.1.5)
+ nokogiri (1.5.0)
+ oauth (0.4.5)
+ oauth-plugin (0.4.0.rc2)
+ multi_json
+ oauth (~> 0.4.4)
+ oauth2
+ rack
+ oauth2 (0.5.2)
+ faraday (~> 0.7)
+ multi_json (~> 1.0)
+ open_id_authentication (1.1.0)
+ rack-openid (~> 1.3)
+ paperclip (2.7.0)
+ activerecord (>= 2.3.0)
+ activesupport (>= 2.3.2)
+ cocaine (>= 0.0.2)
+ mime-types
+ pg (0.13.2)
+ polyglot (0.3.3)
+ rack (1.4.1)
+ rack-cache (1.1)
+ rack (>= 0.4)
+ rack-openid (1.3.1)
+ rack (>= 1.1.0)
+ ruby-openid (>= 2.1.8)
+ rack-ssl (1.3.2)
+ rack
+ rack-test (0.6.1)
+ rack (>= 1.0)
+ rails (3.2.1)
+ actionmailer (= 3.2.1)
+ actionpack (= 3.2.1)
+ activerecord (= 3.2.1)
+ activeresource (= 3.2.1)
+ activesupport (= 3.2.1)
+ bundler (~> 1.0)
+ railties (= 3.2.1)
+ rails-i18n-updater (1.0.1)
+ actionpack
+ activesupport
+ rails
+ railties (3.2.1)
+ actionpack (= 3.2.1)
+ activesupport (= 3.2.1)
+ rack-ssl (~> 1.3.2)
+ rake (>= 0.8.7)
+ rdoc (~> 3.4)
+ thor (~> 0.14.6)
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
+ rinku (1.5.1)
+ ruby-openid (2.1.8)
+ sanitize (2.0.3)
+ nokogiri (>= 1.4.4, < 1.6)
+ sass (3.1.15)
+ sass-rails (3.2.4)
+ railties (~> 3.2.0)
+ sass (>= 3.1.10)
+ tilt (~> 1.3)
+ sprockets (2.1.2)
+ hike (~> 1.2)
+ rack (~> 1.0)
+ tilt (~> 1.1, != 1.3.0)
+ therubyracer (0.9.10)
+ libv8 (~> 3.3.10)
+ thor (0.14.6)
+ tilt (1.3.3)
+ timecop (0.3.5)
+ treetop (1.4.10)
+ polyglot
+ polyglot (>= 0.3.1)
+ tzinfo (0.3.31)
+ uglifier (1.2.3)
+ execjs (>= 0.3.0)
+ multi_json (>= 1.0.2)
+ validates_email_format_of (1.5.3)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ SystemTimer (>= 1.1.3)
+ coffee-rails (~> 3.2.1)
+ composite_primary_keys (>= 5.0.0)
+ deadlock_retry (>= 1.2.0)
+ dynamic_form
+ http_accept_language (>= 1.0.2)
+ httpclient
+ i18n-js
+ iconv
+ jquery-rails
+ libxml-ruby (>= 2.0.5)
+ memcached (>= 1.4.0)
+ oauth-plugin (>= 0.4.0.pre7)
+ open_id_authentication (>= 1.1.0)
+ paperclip (~> 2.0)
+ pg
+ rails (= 3.2.1)
+ rails-i18n-updater
+ rinku (>= 1.2.2)
+ sanitize
+ sass-rails (~> 3.2.3)
+ therubyracer
+ timecop
+ uglifier (>= 1.0.3)
+ validates_email_format_of (>= 1.5.1)

0 comments on commit 3e3026c

Please sign in to comment.