Swvim is a little vim package. It's lightweight and optimized for rails development in terminal vim.
Vim script Shell Ruby
Switch branches/tags
Nothing to show
Clone or download
Pull request Compare This branch is 52 commits ahead, 76 commits behind zirni:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
test
vim
.gitignore
.rbenv-version
Gemfile
README.md
Rakefile
install.sh
swvimrc

README.md

Swvim

Swvim is a little vim package. It's lightweight and optimized for rails development in terminal vim.

Requirements

You need a vim version with ruby interpreter enabled. (for Command-T) Also be sure that you have 256 colors enabled in your terminal.

For example:

~  tput colors
256

➜  ~  echo $TERM
xterm-256color

Setup

Be sure that you don't have any .vim.old .vimrc.old .gvimrc.old in your home directory.

Then do

git clone git@github.com:zirni/swvim.git ~/.swvim
cd ~/.swvim
./install.sh

Now you have to follow these steps to finish the installation:

gem install vim-update-bundles
vim-update-bundles

And now you're ready to go!

Customization

You can add your own configurations in ~/.vimrc.local to customize the config to your needs.

Travis Build Status

Build Status