Permalink
Fetching contributors…
Cannot retrieve contributors at this time
228 lines (159 sloc) 10.1 KB

1.5.3 / Unreleased

1.5.2 / 2015-10-01

Improvements:

  • Support URI-encorded UserInfo for Chef, SVN, Yum (GH-130)
  • Support docker on Debian/Ubuntu with systemd (GH-133)

1.5.1 / 2015-07-25

Bug fixes:

  • Fix docker configuration (GH-106)

1.5.0 / 2015-01-15

Features:

  • Ignore specific applications by passing a hash to config.proxy.enabled (GH-93)
  • Support the chef_zero provisioner in Vagrant 1.7+ (GH-105)

Improvements:

  • Add -f option for mv and rm commands to overrides any -i or -n options in shell aliases (GH-90)
  • Use system-wide configuration for NPM (GH-91)
  • Avoid restarting docker when configuration doesn't change (GH-92)
  • Fix Chef provisioner detection compatibility with Vagrant 1.7+ (GH-103)

Bug fixes:

  • Don't error if removing non-existing git proxy configuration (GH-94)

1.4.0 / 2014-09-28

Features:

  • Support for configuring Docker (GH-69)

1.3.2 / 2014-05-30

Improvements:

  • Ensure that the .npmrc file exists to work around NPM-5065

Bug fixes:

  • Fix /etc/environment for empty end false values

1.3.1 / 2014-05-09

Improvements:

  • Write environment variable configuration also to /etc/environment on Linux (GH-58, GH-67)
    • Fixes compatibility with vagrant-omnibus and non-login shells

1.3.0 / 2014-05-02

Features:

  • Support setting proxy environment variables on Windows guests (GH-63)
  • Support setting proxy environment variables on CoreOS guests (GH-62)
    • Requires CoreOS 286.0 or later

Bug fixes:

  • Fix https proxy configuration for npm if different to http (GH-57)
  • Use absolute paths to git, npm, and pear commands when configuring them using sudo to avoid PATH problems (GH-59, GH-60)

1.2.0 / 2014-03-02

Deprecations:

  • Deprecate config.env_proxy and VAGRANT_ENV_*_PROXY, as config.proxy.* and VAGRANT_*_PROXY should be enough. The env_proxy config options will be removed in v2.0.0.
  • config.apt_proxy.* and VAGRANT_APT_*_PROXY URIs should explicitly set the scheme and port. In v2.0.0 the scheme will be required, and default port will be scheme's default (currently 3142).

Features:

1.1.0 / 2014-02-06

Features:

  • Add config.proxy.enabled option which can be set to false to disable the plugin (GH-39)
  • Support for configuring PEAR (GH-34)

Improvements:

  • Compatibility with Vagrant v1.5:
    • Vagrant.require_plugin deprecated (GH-44)
    • Hook before SyncedFolders action as it can install NFS client (GH-45)
    • Vagrant 1.5.0 is not released at the time of this release, so compatibility can't be guaranteed yet
  • Run Travis tests against all supported Vagrant minor versions with correct Ruby version
  • Decrease noise level, don't print messages when configuring something

Bug fixes:

  • Quote no_proxy in /etc/profile.d/proxy.sh to protect it from spaces (GH-42)

1.0.1 / 2013-12-01

  • Ensure that Yum configuration includes the (default) port (GH-36)

1.0.0 / 2013-11-05

  • Add support for configuring Yum directly (not only via global env vars) (GH-4)
  • Remove the target path before uploading files to VM to avoid permission problems (GH-32)
  • Disable environment variable setting on CoreOS (GH-35)

0.6.0 / 2013-10-15

0.5.3 / 2013-09-30

  • Compatibility with vagrant-aws v0.4.0 (GH-28)
    • Next vagrant-aws release will remove its custom TimedProvision action class
  • Ensure that generated configuration files are not deleted before uploading (GH-29)

0.5.2 / 2013-09-27

  • Fix sudo configuration on old Ubuntu 10.04 "lucid" guests (GH-26)
  • Always set correct permissions on generated configuration files (GH-27, GH-26)

0.5.1 / 2013-09-17

  • Configure sudo to preserve the *_proxy environment variables (GH-23, GH-25)
    • Requires that sudo in VM is configured to support "sudoers.d", i.e. /etc/sudoers contains line #includedir /etc/sudoers.d
  • Fix Chef provisioner configuration if a proxy is set to false (GH-24)
  • Create the directories for configuration files if they don't exist (GH-25)

0.5.0 / 2013-09-11

  • Set default proxy configuration for all Chef provisioners (GH-19, GH-21)

0.4.0 / 2013-09-04

  • BREAKING: Environment variables for Apt config renamed to VAGRANT_APT_HTTP_PROXY etc. (GH-15)
  • Configure all supported programs with a single config.proxy configuration or VAGRANT_HTTP_PROXY etc. environment variables (GH-14, GH-17)
  • Add support for global *_proxy environment variables via config.env_proxy (GH-6)
  • Configure the VM also on vagrant provision (GH-12)
    • Hook to all commands that trigger provisioning action
  • Ensure the proxies are configured before vagrant-omnibus (GH-13)
    • Requires vagrant-omnibus v1.1.1 or newer to work correctly

0.3.0 / 2013-07-12

0.2.0 / 2013-07-05

  • Add Apt proxy configuration for FTP URIs (GH-5)
  • Warn and fail if Vagrant is older than v1.2.0 (GH-7)
  • New home page (GH-8)

0.1.1 / 2013-06-27

  • Don't crash if there is no configuration for us in the Vagrantfiles (GH-2)

0.1.0 / 2013-06-27

  • Initial release
  • Support for Apt proxy configuration
  • Based heavily on vagrant-cachier plugin