New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Option+Shift+arrows triggers template shortcut on Mac #81

Closed
ghost opened this Issue Mar 6, 2012 · 7 comments

Comments

Projects
None yet
1 participant
@ghost

ghost commented Mar 6, 2012

When pressing one of the Option+Shift+arrow key combinations, a pop up is displayed saying: "Sorry! $1 output was empty".

This is on OS X Lion with all the updates.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Mar 6, 2012

...Without Shift in the key combination, nothing is triggered.

ghost commented Mar 6, 2012

...Without Shift in the key combination, nothing is triggered.

@neocotic

This comment has been minimized.

Show comment
Hide comment
@neocotic

neocotic Mar 6, 2012

Member

Are you able to tell me all of the shortcuts you are using?

What do you mean "arrow key combinations"? Does Chrome now use opt+shift hotkeys? What version of Chrome are you using?

Regardless, this sounds like a bug as nothing should happen unless a template is found with a matching end key which I'm currently limiting to alphanumeric characters.

I'll take a look at this when I get home on my Mac. I'm using Snow Leopard but hopefully I'm still able to replicate.

Thanks for reporting this issue.

Member

neocotic commented Mar 6, 2012

Are you able to tell me all of the shortcuts you are using?

What do you mean "arrow key combinations"? Does Chrome now use opt+shift hotkeys? What version of Chrome are you using?

Regardless, this sounds like a bug as nothing should happen unless a template is found with a matching end key which I'm currently limiting to alphanumeric characters.

I'll take a look at this when I get home on my Mac. I'm using Snow Leopard but hopefully I'm still able to replicate.

Thanks for reporting this issue.

@ghost ghost assigned neocotic Mar 6, 2012

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Mar 6, 2012

Are you able to tell me all of the shortcuts you are using?

Just the standard ones, for now.

What do you mean "arrow key combinations"?

These trigger the pop up:

  • Option+Shift+Left Arrow
  • Option+Shift+Right Arrow
  • Option+Shift+Up Arrow
  • Option+Shift+Down Arrow

Does Chrome now use opt+shift hotkeys?

I use the aforementioned key combinations all the time in text fields -- they work in all Mac apps to select word-by-word.

What version of Chrome are you using?

The latest stable one.

Thanks for reporting this issue.

No problem. I'm the one who should thank you for this great extension! :)

ghost commented Mar 6, 2012

Are you able to tell me all of the shortcuts you are using?

Just the standard ones, for now.

What do you mean "arrow key combinations"?

These trigger the pop up:

  • Option+Shift+Left Arrow
  • Option+Shift+Right Arrow
  • Option+Shift+Up Arrow
  • Option+Shift+Down Arrow

Does Chrome now use opt+shift hotkeys?

I use the aforementioned key combinations all the time in text fields -- they work in all Mac apps to select word-by-word.

What version of Chrome are you using?

The latest stable one.

Thanks for reporting this issue.

No problem. I'm the one who should thank you for this great extension! :)

@neocotic

This comment has been minimized.

Show comment
Hide comment
@neocotic

neocotic Mar 6, 2012

Member

It appears that a notification will appear for all shortcuts using this modifier on the Mac. This bug may also exist on other operating systems as well as I can't see why this would be Mac-specific.

I'll start debugging this problem now as it's potentially quite a wide-spread issue and may require another hotfix.

Member

neocotic commented Mar 6, 2012

It appears that a notification will appear for all shortcuts using this modifier on the Mac. This bug may also exist on other operating systems as well as I can't see why this would be Mac-specific.

I'll start debugging this problem now as it's potentially quite a wide-spread issue and may require another hotfix.

@neocotic

This comment has been minimized.

Show comment
Hide comment
@neocotic

neocotic Mar 7, 2012

Member

OK, I've identified the problem and testing a fix for it now. It's really simple and I wish I spotted this earlier. Also noticed that the template data was being collected even when the an unregistered shortcut was triggered.

I'm aiming to get this fix live today due to the nature of it. I'm also hoping to deliver some behind-the-scenes changes to i18n bundles for #80.

Member

neocotic commented Mar 7, 2012

OK, I've identified the problem and testing a fix for it now. It's really simple and I wish I spotted this earlier. Also noticed that the template data was being collected even when the an unregistered shortcut was triggered.

I'm aiming to get this fix live today due to the nature of it. I'm also hoping to deliver some behind-the-scenes changes to i18n bundles for #80.

@neocotic

This comment has been minimized.

Show comment
Hide comment
@neocotic

neocotic Mar 7, 2012

Member

This fix has been included in the latest update. I've tested this and I'm happy with the results so I'm closing this issue off now. If you are still experiencing problems after the update please feel free to reopen this issue.

Member

neocotic commented Mar 7, 2012

This fix has been included in the latest update. I've tested this and I'm happy with the results so I'm closing this issue off now. If you are still experiencing problems after the update please feel free to reopen this issue.

@neocotic neocotic closed this Mar 7, 2012

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Mar 8, 2012

Thanks for the fix, neocotic!

ghost commented Mar 8, 2012

Thanks for the fix, neocotic!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment