Permalink
Browse files

updated gems

  • Loading branch information...
1 parent b5a05f8 commit 89cffee5293035c3ce1ee27dd635eeb519a4292a @aziz aziz committed Sep 9, 2012
Showing with 39 additions and 41 deletions.
  1. +3 −4 Gemfile
  2. +17 −15 Gemfile.lock
  3. +7 −7 Rakefile
  4. +12 −15 tmuxinator.gemspec
View
7 Gemfile
@@ -1,8 +1,7 @@
source "http://rubygems.org"
group :development do
- gem "rspec", "~> 2.6.0"
- gem "bundler", "~> 1.1.rc"
- gem "jeweler", "~> 1.6.4"
- gem "rcov", "~> 0.9.10"
+ gem "rspec", "~> 2.11.0"
+ gem "bundler", "~> 1.2.0"
+ gem "jeweler", "~> 1.8.4"
end
View
32 Gemfile.lock
@@ -3,26 +3,28 @@ GEM
specs:
diff-lcs (1.1.3)
git (1.2.5)
- jeweler (1.6.4)
+ jeweler (1.8.4)
bundler (~> 1.0)
git (>= 1.2.5)
rake
- rake (0.9.2)
- rcov (0.9.10)
- rspec (2.6.0)
- rspec-core (~> 2.6.0)
- rspec-expectations (~> 2.6.0)
- rspec-mocks (~> 2.6.0)
- rspec-core (2.6.4)
- rspec-expectations (2.6.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.6.0)
+ rdoc
+ json (1.7.5)
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
+ rspec (2.11.0)
+ rspec-core (~> 2.11.0)
+ rspec-expectations (~> 2.11.0)
+ rspec-mocks (~> 2.11.0)
+ rspec-core (2.11.1)
+ rspec-expectations (2.11.3)
+ diff-lcs (~> 1.1.3)
+ rspec-mocks (2.11.2)
PLATFORMS
ruby
DEPENDENCIES
- bundler (~> 1.1.rc)
- jeweler (~> 1.6.4)
- rcov (~> 0.9.10)
- rspec (~> 2.6.0)
+ bundler (~> 1.2.0)
+ jeweler (~> 1.8.4)
+ rspec (~> 2.11.0)
View
14 Rakefile
@@ -24,23 +24,23 @@ Jeweler::Tasks.new do |gem|
..........................................................
Thank you for installing tmuxinator
- Please be sure to to drop a line in your ~/.bashrc file, similar
+ Please be sure to to drop a line in your ~/.bashrc file, similar
to RVM if you've used that before:
[[ -s $HOME/.tmuxinator/scripts/tmuxinator ]] && source $HOME/.tmuxinator/scripts/tmuxinator
-
+
also ensure that you've set these variables in your ENV:
-
+
$EDITOR, $SHELL
-
+
you can run `tmuxinator doctor` to make sure everything is set.
happy tmuxing with tmuxinator!
..........................................................
__________________________________________________________
-
+
}
-
+
# Include your dependencies below. Runtime dependencies are required when using your gem,
# and development dependencies are only needed for development (ie running rake tasks, tests, etc)
# gem.add_runtime_dependency 'jabber4r', '> 0.1'
@@ -61,7 +61,7 @@ end
task :default => :spec
-require 'rake/rdoctask'
+require 'rdoc/task'
Rake::RDocTask.new do |rdoc|
version = File.exist?('VERSION') ? File.read('VERSION') : ""
View
27 tmuxinator.gemspec
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Allen Bargi"]
- s.date = "2011-10-10"
+ s.date = "2012-09-09"
s.description = "Create and manage complex tmux sessions easily."
s.email = "allen.bargi@gmail.com"
s.executables = ["mux", "tmuxinator", "tmuxinator_completion"]
@@ -41,30 +41,27 @@ Gem::Specification.new do |s|
]
s.homepage = "http://github.com/aziz/tmuxinator"
s.licenses = ["MIT"]
- s.post_install_message = "\n __________________________________________________________\n ..........................................................\n\n Thank you for installing tmuxinator\n Please be sure to to drop a line in your ~/.bashrc file, similar \n to RVM if you've used that before:\n\n [[ -s $HOME/.tmuxinator/scripts/tmuxinator ]] && source $HOME/.tmuxinator/scripts/tmuxinator\n \n also ensure that you've set these variables in your ENV:\n \n $EDITOR, $SHELL\n \n you can run `tmuxinator doctor` to make sure everything is set.\n happy tmuxing with tmuxinator!\n\n ..........................................................\n __________________________________________________________\n \n "
+ s.post_install_message = "\n __________________________________________________________\n ..........................................................\n\n Thank you for installing tmuxinator\n Please be sure to to drop a line in your ~/.bashrc file, similar\n to RVM if you've used that before:\n\n [[ -s $HOME/.tmuxinator/scripts/tmuxinator ]] && source $HOME/.tmuxinator/scripts/tmuxinator\n\n also ensure that you've set these variables in your ENV:\n\n $EDITOR, $SHELL\n\n you can run `tmuxinator doctor` to make sure everything is set.\n happy tmuxing with tmuxinator!\n\n ..........................................................\n __________________________________________________________\n\n "
s.require_paths = ["lib"]
- s.rubygems_version = "1.8.11"
+ s.rubygems_version = "1.8.23"
s.summary = "Create and manage complex tmux sessions easily."
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rspec>, ["~> 2.6.0"])
- s.add_development_dependency(%q<bundler>, ["~> 1.0.18"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_development_dependency(%q<rcov>, ["~> 0.9.10"])
+ s.add_development_dependency(%q<rspec>, ["~> 2.11.0"])
+ s.add_development_dependency(%q<bundler>, ["~> 1.2.0"])
+ s.add_development_dependency(%q<jeweler>, ["~> 1.8.4"])
else
- s.add_dependency(%q<rspec>, ["~> 2.6.0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.18"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rcov>, ["~> 0.9.10"])
+ s.add_dependency(%q<rspec>, ["~> 2.11.0"])
+ s.add_dependency(%q<bundler>, ["~> 1.2.0"])
+ s.add_dependency(%q<jeweler>, ["~> 1.8.4"])
end
else
- s.add_dependency(%q<rspec>, ["~> 2.6.0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.18"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rcov>, ["~> 0.9.10"])
+ s.add_dependency(%q<rspec>, ["~> 2.11.0"])
+ s.add_dependency(%q<bundler>, ["~> 1.2.0"])
+ s.add_dependency(%q<jeweler>, ["~> 1.8.4"])
end
end

0 comments on commit 89cffee

Please sign in to comment.