Skip to content
ShopQi - 网上开店新选择
Ruby JavaScript CoffeeScript Shell
Find file
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
app
config
db
doc
lib
public
script
spec
vendor/plugins
.gitignore
.rspec
.travis.yml
Gemfile
Gemfile.lock
Guardfile
README.textile
Rakefile
Vagrantfile
Vagrantfile.pkg
config.ru

README.textile

ShoqQi

中国开源电子商务平台,基于rails3开发
注意:现阶段ShopQi处于频繁更新中(有破坏性),仅用于学习研究,请勿部署在生产环境

安装

为了便于安装,ShopQi的开发环境将基于Vagrant虚拟工具
关于vagrant的安装使用可参考 http://saberma.me/linux/2011/03/03/vagrant-virtual-develop-enviroment.html

安装VirtualBox

参考这里安装VirtualBox 4.x: http://www.virtualbox.org/wiki/Downloads

安装Vagrant和PostgrelSQL客户端

pre.
sudo apt-get install postgresql-client libpq-dev
gem install vagrant —no-ri —no-rdoc

下载ShopQi虚拟镜像文件

下载镜像文件(622M): http://u.115.com/file/f11253dfb5
假设下载地址为 ~/vagrant-package-shopqi-new.box
下载完成后执行

vagrant box add lucid32-shopqi-new ~/vagrant-package-shopqi-new.box

虚拟机默认安装以下组件:

  1. Ubuntu 10.04(32bit)
  2. Ruby 1.9.2
  3. Ruby on Rails 3.0.6
  4. unicorn 3.5.0
  5. postgrel 0.8.4
  6. redis 2.2.0rc2
  7. coreseek(sphinx) 3.2.14

下载源代码:

git clone git://github.com/saberma/shopqi.git 
cd shopqi

创建虚拟机

#require nfsd for share folder
sudo apt-get install nfs-kernel-server
vagrant up

查看效果

测试用户名密码都为admin@shopqi.com
登录 http://lvh.me:3000

开发人员

saberma

  1. email(gtalk): mahb45 # gmail.com
  2. twitter: twitter.com/saberma

weihuilee

  1. email(gtalk): liwh87 # gmail.com
  2. twitter: twitter.com/weihuilee

License

产品协议: GNU Affero GPL 3

Something went wrong with that request. Please try again.