Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

flent-gui not launching from Cygwin environment on Windows 10 #159

Closed
cklatsky opened this issue Mar 19, 2019 · 2 comments

Comments

Projects
None yet
2 participants
@cklatsky
Copy link

commented Mar 19, 2019

Hi,

I have a new setup that I am trying to get Flent gui to run, so I may view test output files. The setup is Cygwin environment running on Windows 10. Cygwin definition copied below from Wikipedia. I have all the packages installed successfully, but I get this output when trying to launch the gui:
CKlats000@HQSWL-c029872 ~
$ flent --new-gui-instance
Started Flent 1.2.2 using Python 2.7.15.
font search path ['/usr/lib/python2.7/site-packages/matplotlib/mpl-data/fonts/ttf', '/usr/lib/python2.7/site-packages/matplotlib/mpl-data/fonts/afm', '/usr/lib/python2.7/site-packages/matplotlib/mpl-data/fonts/pdfcorefonts']
generated new fontManager
Initialised matplotlib v2.2.4 on numpy v1.11.2.
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-CKlats000'
qt.qpa.screen: QXcbConnection: Could not connect to display
Could not connect to any X display.

I am thinking maybe it is just some environment variable that needs to be set, but not sure which one. Any suggestions?

+++++++++ Cygwin environment summary+++++++++
Cygwin is a POSIX-compatible environment that runs natively on Microsoft Windows. Its goal is to allow programs of Unix-like systems to be recompiled and run natively on Windows with minimal source code modifications by providing them with the same underlying POSIX API they would expect in those systems. Wikipedia

@tohojo

This comment has been minimized.

Copy link
Owner

commented Mar 19, 2019

@cklatsky

This comment has been minimized.

Copy link
Author

commented Mar 28, 2019

Hi Toke,

Got it. Started the X server, then I was able to launch flent --new-gui-instance

Thanks!
-Carl

@cklatsky cklatsky closed this Mar 28, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.