Skip to content
Permalink
Browse files

chore(release): 0.3.0

  • Loading branch information...
regalius committed Mar 26, 2019
1 parent 8dcf5dc commit 04c1bec49dba992f95e76b3c8accd53fccd92cad
@@ -2,6 +2,21 @@

All notable changes to this project will be documented in this file. See [standard-version](https://github.com/conventional-changelog/standard-version) for commit guidelines.

<a name="0.3.0"></a>
# [0.3.0](https://github.com/tokopedia/treats/compare/v0.2.0...v0.3.0) (2019-03-26)


### Bug Fixes

* fix vulnerable dependencies ([#31](https://github.com/tokopedia/treats/issues/31)) ([8dcf5dc](https://github.com/tokopedia/treats/commit/8dcf5dc))


### Features

* **workbox-webpack-plugin:** added workbox-webpack-plugin ([#26](https://github.com/tokopedia/treats/issues/26)) ([89bc48e](https://github.com/tokopedia/treats/commit/89bc48e))



<a name="0.2.0"></a>
# 0.2.0 (2019-02-26)

@@ -22,6 +22,6 @@
"test:coverage": "treats test --coverage"
},
"dependencies": {
"treats": "0.2.0"
"treats": "0.3.0"
}
}
@@ -22,6 +22,6 @@
"test:coverage": "treats test --coverage"
},
"dependencies": {
"treats": "0.2.0"
"treats": "0.3.0"
}
}
@@ -9,6 +9,6 @@
},
"author": "Tokopedia Engineering",
"peerDependencies": {
"treats": "0.2.0"
"treats": "0.3.0"
}
}
@@ -1,6 +1,6 @@
{
"name": "my-treats-app",
"version": "0.2.0",
"version": "0.3.0",
"description": "My First Treats App",
"license": "ISC",
"scripts": {
@@ -20,6 +20,6 @@
},
"dependencies": {
"@treats/my-first-addons": "^1.0.0",
"treats": "0.2.0"
"treats": "0.3.0"
}
}
@@ -1,6 +1,6 @@
{
"name": "emotion-example",
"version": "0.2.0",
"version": "0.3.0",
"description": "Emotion Critical CSS Example",
"license": "ISC",
"scripts": {
@@ -22,7 +22,7 @@
"emotion": "9.2.12",
"emotion-server": "9.2.12",
"react-emotion": "9.2.12",
"treats": "0.2.0"
"treats": "0.3.0"
},
"devDependencies": {
"babel-plugin-emotion": "9.2.11"
@@ -1,6 +1,6 @@
{
"name": "emotion-css",
"version": "0.2.0",
"version": "0.3.0",
"description": "Emotion CSS Example",
"license": "ISC",
"scripts": {
@@ -22,7 +22,7 @@
"emotion": "9.2.12",
"emotion-server": "9.2.12",
"react-emotion": "9.2.12",
"treats": "0.2.0"
"treats": "0.3.0"
},
"devDependencies": {
"babel-plugin-emotion": "9.2.11"
@@ -1,6 +1,6 @@
{
"name": "less-css",
"version": "0.2.0",
"version": "0.3.0",
"description": "Less CSS example",
"license": "ISC",
"scripts": {
@@ -19,7 +19,7 @@
"documentation:flush": "treats documentation flush src/"
},
"dependencies": {
"treats": "0.2.0",
"treats": "0.3.0",
"less": "2.3.1"
}
}
@@ -1,6 +1,6 @@
{
"name": "sass-css",
"version": "0.2.0",
"version": "0.3.0",
"description": "Sass CSS example",
"license": "ISC",
"scripts": {
@@ -19,7 +19,7 @@
"documentation:flush": "treats documentation flush src/"
},
"dependencies": {
"treats": "0.2.0",
"treats": "0.3.0",
"node-sass": "4.10.0"
}
}
@@ -1,6 +1,6 @@
{
"name": "styled-components",
"version": "0.2.0",
"version": "0.3.0",
"description": "Styled Components Example",
"license": "ISC",
"scripts": {
@@ -20,7 +20,7 @@
},
"dependencies": {
"styled-components": "4.1.1",
"treats": "0.2.0"
"treats": "0.3.0"
},
"devDependencies": {
"babel-plugin-styled-components": "1.8.0"
@@ -22,8 +22,8 @@
"test:coverage": "treats test --coverage"
},
"dependencies": {
"@treats/addons-base": "0.2.0",
"@treats/addons-base": "0.3.0",
"axios": "^0.18.0",
"treats": "0.2.0"
"treats": "0.3.0"
}
}
@@ -22,7 +22,7 @@
"test:coverage": "treats test --coverage"
},
"dependencies": {
"treats": "0.2.0",
"treats": "0.3.0",
"typescript": "3.2.2",
"@types/enzyme": "3.1.15",
"@types/jest": "23.3.10",
@@ -1,6 +1,6 @@
{
"lerna": "2.11.0",
"version": "0.2.0",
"version": "0.3.0",
"packages": [
"packages/*"
]
@@ -1,6 +1,6 @@
{
"name": "treats-repo",
"version": "0.2.0",
"version": "0.3.0",
"description": "Tokopedia React Development Kits Repository",
"author": "Tokopedia Engineering",
"license": "Apache-2.0",
@@ -1,12 +1,12 @@
{
"name": "@treats/addons-base",
"license": "Apache-2.0",
"version": "0.2.0",
"version": "0.3.0",
"description": "Treats Addons Base",
"main": "index.js",
"author": "Tokopedia Engineering",
"peerDependencies": {
"treats": "0.2.0"
"treats": "0.3.0"
},
"dependencies": {
"bluebird": "3.5.1",
@@ -22,7 +22,7 @@
"test:coverage": "treats test --coverage"
},
"dependencies": {
"treats": "0.2.0<%if(USE_TYPESCRIPT)%>",
"treats": "0.3.0<%if(USE_TYPESCRIPT)%>",
"typescript": "3.2.2",
"@types/enzyme": "3.1.15",
"@types/jest": "23.3.10",
@@ -1,7 +1,7 @@
{
"name": "create-treats-app",
"license": "Apache-2.0",
"version": "0.2.0",
"version": "0.3.0",
"description": "Create Treats App",
"main": "./index.js",
"bin": {
@@ -1,7 +1,7 @@
{
"name": "eslint-config-treats",
"license": "Apache-2.0",
"version": "0.2.0",
"version": "0.3.0",
"description": "Eslint config for opinonated development with Treats",
"main": "index.js",
"scripts": {
@@ -1,7 +1,7 @@
{
"name": "stylelint-config-treats",
"license": "Apache-2.0",
"version": "0.2.0",
"version": "0.3.0",
"description": "Stylelint config for opinionated development with Treats",
"main": "index.js",
"scripts": {
@@ -1,7 +1,7 @@
{
"name": "treats",
"license": "Apache-2.0",
"version": "0.2.0",
"version": "0.3.0",
"description": "Tokopedia React Development Kits",
"author": "Tokopedia Engineering",
"types": "./lib/treats.d.ts",

0 comments on commit 04c1bec

Please sign in to comment.
You can’t perform that action at this time.