Skip to content
Newer
Older
100644 26 lines (19 sloc) 894 Bytes
ea22c57 @thomasdarde Version has it own file.
thomasdarde authored
1 # encoding: utf-8
2ed9b8e @thomasdarde Gemspec update, was requiring a rails_admin path.
thomasdarde authored
2 require File.expand_path('../lib/tolk/version', __FILE__)
ea22c57 @thomasdarde Version has it own file.
thomasdarde authored
3
a496269 @lifo Add a gemspec
lifo authored
4 Gem::Specification.new do |s|
29576df @dhh The lines must line up
dhh authored
5 s.name = 'tolk'
ea22c57 @thomasdarde Version has it own file.
thomasdarde authored
6 s.version = Tolk::VERSION
29576df @dhh The lines must line up
dhh authored
7 s.summary = 'Rails engine providing web interface for managing i18n yaml files'
cc96ff9 @lifo Fix gemspec
lifo authored
8 s.description = 'Tolk is a web interface for doing i18n translations packaged as an engine for Rails applications.'
a496269 @lifo Add a gemspec
lifo authored
9
2ed9b8e @thomasdarde Gemspec update, was requiring a rails_admin path.
thomasdarde authored
10 s.authors = ['David Heinemeier Hansson', 'Piotr Sarnacki', 'Emilio Tagua', 'Thomas Darde']
a496269 @lifo Add a gemspec
lifo authored
11 s.email = 'david@loudthinking.com'
809c390 @thomasdarde Gemspec update for version 1.1.0
thomasdarde authored
12 s.homepage = 'http://github.com/tolk/tolk'
a496269 @lifo Add a gemspec
lifo authored
13
29576df @dhh The lines must line up
dhh authored
14 s.platform = Gem::Platform::RUBY
96e3ddc @drogus Do not require specific version of will paginate
drogus authored
15 s.add_dependency('will_paginate')
cc96ff9 @lifo Fix gemspec
lifo authored
16 s.add_dependency('ya2yaml', '~> 0.26')
a496269 @lifo Add a gemspec
lifo authored
17
6f7f202 @thomasdarde Adding a post install message to gem spec.
thomasdarde authored
18 if File.exists?('UPGRADING')
19 s.post_install_message = File.read("UPGRADING")
20 end
21
a496269 @lifo Add a gemspec
lifo authored
22 s.files = Dir['README', 'MIT-LICENSE', 'config/routes.rb', 'init.rb', 'lib/**/*', 'app/**/*', 'public/tolk/**/*']
23
24 s.require_path = 'lib'
25 end
Something went wrong with that request. Please try again.